Text formatting produces duplicates

VERIFIED WORKSFORME

Status

()

Core
Editor
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: kmurray1115, Assigned: kinmoz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
branch 2001-10-16
Win2k

Summary: Formatting text as bold or italic duplicates selected text and deposits
it, unformatted, at the end of the selection. 

Weird. I was in Composer and I selected text which I then hit ctrl+i to set it
to italics, and the weirdest thing happened. My selection "foobar" became
"foobarfoobar" with the first foobar in italics. I tried the same thing with
bold and it produced the same result.

More specific steps:
1. Launch a blank page in Composer
2. start typing a sentence (in my scenario, I had my text in blockquotes, moved
over two ticks with the ==> button)
3. select the last word in your sample sentence
4. Use ctrl+i to set to italics
Result: duplicate
Expected Result: duh!

Comment 1

17 years ago
I tried reproducing this:

1) new blank page
2) enable blockquote mode(tried Normal mode also)
3) type a sentence
4) select last word in sentence
5) Ctrl-I to italicize

I don't see a duplicated word. works fine for me..

I"m using Win 98 but that shouldn't matter.

Kevin, can you reproduce your problem everytime? or was it
something that only happened once?
(Assignee)

Comment 2

17 years ago
I can't reproduce this either. Kevin which branch build were you using?

In any case this sounds like bug 98544 (which is a dup of a bug that doesn't 
sound related, but is) which was fixed on the TRUNK, but was deemed too risky to 
land on the 0.9.2 or 0.9.4 branch.

Kevin, if you see this problem in the TRUNK or can give us updated steps on how 
to reproduce this, please reopen.

It would be helpful to see what exactly the content was you had in the window 
at the time this happened. Also knowing things like if the sentence you said to 
type was supposed to wrap or not might help.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 3

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.