Find My Device web UI spins forever if my phone's geolocation is turned off

RESOLVED DUPLICATE of bug 1033924

Status

Firefox OS
FindMyDevice
RESOLVED DUPLICATE of bug 1033924
4 years ago
4 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
STR:
 1. Enable "Find My Device" in Settings on your phone.
 2. Turn off Geolocation in Settings on your phone.
 3. In a browser, visit https://find.firefox.com/ and sign in.

ACTUAL RESULTS:
The find.firefox.com site says "Connecting to device..." and has the "loading" binoculars-throbber spinning continuously, forever.  Never changes / times out.

EXPECTED RESULTS:
Should either:
 (1) forcibly turn on my device's geolocation setting, and give me the location
...or, if that's not possible...
 (2) time out and tell me that it was unable to locate my phone
(Reporter)

Comment 1

4 years ago
(We probably should have (2) implemented as a fallback, but (1) would be great if we can get it as well.)

Comment 2

4 years ago
I think this is similar to this bug: 1033924
(Reporter)

Comment 3

4 years ago
Yeah, you're right. I'll dupe it to that bug. (I don't think that bug covers my Expected Results part (1), but I'll spin off a more targeted bug for that.)

Comment 4

4 years ago
Thanks Daniel!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033924
(Reporter)

Comment 5

4 years ago
I spun off bug 1053452 to cover remotely enabling geolocation.
You need to log in before you can comment on or make changes to this bug.