[Settings][Gecko] Refactor a lot of the duplicate simple Settings parsers

RESOLVED DUPLICATE of bug 1053966

Status

RESOLVED DUPLICATE of bug 1053966
4 years ago
4 years ago

People

(Reporter: mikeh, Assigned: mikeh)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

A lot of these do exactly the same thing:
http://dxr.mozilla.org/mozilla-central/search?q=ParseJSON+ext%3Acpp&case=true&redirect=true

Move the common logic into one place.
Summary: [Settins][Gecko] Refactor a lot of the duplicate simple Settings parses → [Settings][Gecko] Refactor a lot of the duplicate simple Settings parses
(Wow, I can't type today.)
Summary: [Settings][Gecko] Refactor a lot of the duplicate simple Settings parses → [Settings][Gecko] Refactor a lot of the duplicate simple Settings parsers
Bug 1053966 wound up subsuming this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1053966
You need to log in before you can comment on or make changes to this bug.