<button> content overflows into padding when overflow:hidden, text-overflow: ellipsis and white-space: nowrap is specified

RESOLVED DUPLICATE of bug 1010675

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1010675
4 years ago
4 years ago

People

(Reporter: Theodore, Unassigned)

Tracking

({testcase})

31 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Created a button with padding, a max-width, overflow: hidden, white-space: nowrap, and text-overflow: ellipsis.


Actual results:

The button's text content overflowed into the padding. This prevents me from absolutely positioning other content within the padding.

I also reproduced the bug in today's nightly.


Expected results:

The text should have been cut off before the padding (as occurs in Chrome and Internet Explorer 11). See http://jsfiddle.net/theodorejb/kfzq4911/.

Comment 1

4 years ago
I juggled up http://jsbin.com/jucenu/1/edit to compare with a <div>, which works fine (set to border-box layout so it better corresponds in size to the <button> ).
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
Summary: Content overflows into padding when overflow:hidden is specified → <button> content overflows into padding when overflow:hidden, text-overflow: ellipsis and white-space: nowrap is specified

Updated

4 years ago
OS: Windows 8.1 → All
Hardware: x86_64 → All
Created attachment 8472681 [details]
testcase 1

Here's another testcase comparing to a <div> (similar to Gijs' -- only noticed his after making this one).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1010675
You need to log in before you can comment on or make changes to this bug.