My addons aren't working correctly anymore, and when I try to log in to add-ons, wether from my android device or from PC, I can't




Firefox for Android
4 years ago
2 years ago


(Reporter: gadgety, Unassigned)


31 Branch

Firefox Tracking Flags

(Not tracked)




4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I've got great add-ons on Firefox for Android. My favourite is the Home Feeds 0.8 RSS feed to home screen. It's not updating the feeds. 

When I try to log in to add-ons, it says I haven't got the password. When  try to change the password I get "oops! not allowed." I've filed a separate bug for "oops! not allowed" on regular Firefox because it happens on the PC as well. Here I'm posting because the addon isn't working anymore.

Actual results:

Home feeds do not update any longer.

Expected results:

RSS feeds should update. Log in to Add ons should work


4 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Thanks for reporting. I also see an Add-on review 'not useful, doesn't update the feeds.', so maybe something is up?

> When I try to log in to add-ons, it says I haven't got the password.

What do you mean 'log-in to add-ons'?

> RSS feeds should update.

Margaret, have you seen this?

>  Log in to Add ons should work

Again, what do you mean 'log in to Add ons'?
Component: Plugins → General
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(gadgety)

Comment 2

4 years ago
I haven't seen this issue specifically. What version of Firefox for Android are you using?

Do you know how to get a log from your device? If so, could you see if any errors are appearing?
Flags: needinfo?(margaret.leibovic)


4 years ago
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE

Comment 3

4 years ago
Hi both,

First, thank you, both for answering. I also want you to know this add on is 100% responsible for my using Firefox on Android instead of Chrome (even though Firefox loads slower, specially pictures) because the app is fantastic.

My device Samsung Galaxy Note 8.0 tablet, running Android 4.1.2, Firefox 31.0.

What I mean by "logging in to add-ons", is logging in here "", which I assume is part of the marketplace (?). I wanted to log in because I wrote a review of Home Feed 0.8 a little too early, and made a suggestion for a feature in that review which in hindsight wasn't necessary, so I wanted to revise it (I hadn't realized I could swipe for the next feed, i.e. without selecting the feed at the top of the page).

I haven't attempted to get a log from my device previously. I searched for suggestions on the web, and it seems I need to install an app for it. Any recommendation of which one to use?

Thank you.

BTW, why change to "resolved"? This hasn't been resolved, has it? I don't get the jargon here, I suppose.
Flags: needinfo?(gadgety)
Resolution: INCOMPLETE → ---

Comment 4

4 years ago
I'm not the "not useful, doesn't update the feeds" comment among the reviews. 

Today for some reason, I managed to change my password and log in (hasn't been working for a month) to and change my review. I also took the opportunity to uninstall, and then reinstall Home Feeds to see if it changed the updates. It didn't. They're all from 8-9 of Aug.
Any troubles with should be reported against the website on Bugzilla here:

Aside, what feeds are you using with the add-on? Can you provide a link to them?

To capture a log in Android 4.1, you won't be able to use a Play Store application without root-access, you can try Logcat Extreme if you do have root on your device ( otherwise, you'll need to do it with using the 'logcat' tool provided in the Android SDK, which is a public free download.

Comment 6

4 years ago
Hi Aaron,

Thank you for the reply. So I should enter a new bug in the link above? 

OK, thank you for the info on the PS applications with 4.1. It would have to be logcat from the SDK since my tablet isn't rooted.

Thanks. Here's a selection of a couple of feeds. which all work on my PC with the Firefox browser 31.0:
I tried the Ars feed and pulled to refresh on the panels added from those feeds and it worked for me, they pulled in content fine. I am using Home Feed 0.9 ( which is in-test. Also, tried Home Feed 0.8 and it works as well. Tested using Firefox Beta and Firefox and Nightly on Google Play.

I suggest uninstalling Home Feed from the add-on manager, and re-installing either the newer version or the version on AMO, and try re-adding those feeds.
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.