Closed Bug 1053698 Opened 5 years ago Closed 5 years ago

[MTP] MTP cannot work on Unagi

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1049240

People

(Reporter: alchen, Unassigned)

References

Details

Now MTP server use "/storage/sdcard" as root directory.
However, there is no this folder on Unagi.
On Unagi, the folder should be "/mnt/sdcard"
Besides, there is another part we need to take care.
On Flame, we have internal storage and sdcard.
So "storage/sdcard1" should also be added into our MTP server.

Hi Dave,
Do you have any good idea about these two cases?
Flags: needinfo?(dhylands)
Blocks: mtp
This should be handled as part of bug 1049240

The way that it will work is that the AutoMounter will be tracking the status of the various volumes, and when volumes are available for use, they will be added to the MTP Server, and when they're not available for use, they'll be removed from the MTP server.

Each volume knows its own mount point, and the AutoMounter will use that path when it creates the MtpStorage. The initial version was really just a hack for the flame.
Flags: needinfo?(dhylands)
Close this as resolved duplicate of bug 1049240 per comment 2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049240
You need to log in before you can comment on or make changes to this bug.