Closed Bug 1053826 Opened 7 years ago Closed 7 years ago

Self-assignment in mock_navigator_moz_wifi_manager.js

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Linux
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: max, Assigned: macajc)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
fcampo
: review+
Details | Review
On line 10 (https://github.com/mozilla-b2g/gaia/blob/master/apps/operatorvariant/test/unit/mock_navigator_moz_wifi_manager.js#L10):

  function mwm_setNetworks(networks) {
    networks = networks;
  }

should be

  function mwm_setNetworks(nw) {
    networks = nw;
  }

or something along those lines.
Hi Carmen,

Can you fix this reported issue?

MockNavigatorMozWifiManager's |setNetwork (networks)| method won't actually save the supplied list of networks as intended. There's also a shared MockNavigatorMozWifiManager [1] that also implements this method but without the problem reported in this bug.

Can you and Jose also say why the operatorvariant [2] and FTU [3][4] tests aren't both using the same shared implementation [1]?

Thanks!
Mike

[1] https://github.com/mozilla-b2g/gaia/blob/master/shared/test/unit/mocks/mock_navigator_moz_wifi_manager.js#L21
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/operatorvariant/test/unit/known_networks_customizer_test.js#L5
[3] https://github.com/mozilla-b2g/gaia/blob/master/apps/ftu/test/unit/wifi_test.js#L5
[4] https://github.com/mozilla-b2g/gaia/blob/master/apps/ftu/test/unit/mock_wifi_helper.js#L3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jmcf)
Flags: needinfo?(carmen.jimenezcabezas)
See Also: → 978785
I didn't use the shared mock component because it didn't had the functionality I needed and didn't want to impact other tests that relied on the shared mock. 
Since I'm on PTO, will fix only the reported problem here, and will fix the tests to use the shared component (and modify it) when I return from PTO
Flags: needinfo?(carmen.jimenezcabezas)
Assignee: nobody → carmen.jimenezcabezas
Attached file V1 Proposed patch
Attachment #8479821 - Flags: review?(fernando.campo)
Comment on attachment 8479821 [details] [review]
V1 Proposed patch

minor polish but needed for clarity, no need for tests as it's just re-naming, thanks.
Attachment #8479821 - Flags: review?(fernando.campo) → review+
https://github.com/mozilla-b2g/gaia/commit/1d8fa902c616baef69d16d7ead20cc07c482d16d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Flags: needinfo?(jmcf)
You need to log in before you can comment on or make changes to this bug.