[JavaScript Error: "TypeError: r is undefined" {file: "app://packaged.marketplace.allizom.org/media/js/include.js" line: 10}]

RESOLVED WORKSFORME

Status

Marketplace
Consumer Pages
P1
critical
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: krupa, Unassigned)

Tracking

({regression})

x86
Gonk (Firefox OS)
regression
Points:
---

Details

(Reporter)

Description

4 years ago
Connectivity: wifi with data roaming enabled
SIM used: Movistar Spain
Gaia/device: 1.4/hamachi


steps to reproduce:
1. Launch marketplace stage packaged app


observed behavior:
stage is stuck on the loading screen because of 08-14 09:41:42.039 E/GeckoConsole(  711): [JavaScript Error: "TypeError: r is undefined" {file: "app://packaged.marketplace.allizom.org/media/js/include.js" line: 10}]

https://pastebin.mozilla.org/5979856
(Reporter)

Updated

4 years ago
Summary: 08-14 09:41:42.039 E/GeckoConsole( 711): [JavaScript Error: "TypeError: r is undefined" {file: "app://packaged.marketplace.allizom.org/media/js/include.js" line: 10}] → [JavaScript Error: "TypeError: r is undefined" {file: "app://packaged.marketplace.allizom.org/media/js/include.js" line: 10}]

Updated

4 years ago
Blocks: 1033040
I can’t reproduce on feed packages, but I can somewhat reliably on non-feed packages. I'm tempted to unblock from 1033040, but Krupa said that she experiences it intermittently on feed packages, so I'll leave it for now.

If anybody can get a stack trace of this error from a nonminified environment, it would be greatly appreciated.

Updated

4 years ago
Priority: -- → P1
I still can't reproduce this, not sure where to go from here.

Maybe cvan has insight?
Krupa was not getting this either, as of yesterday. If it can't be reproduced today, we should close it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.