Closed Bug 1053897 Opened 8 years ago Closed 7 years ago

Intermittent contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search phrase highlightded correctly for first letter | Error: expected false to be true

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 fixed)

RESOLVED FIXED
Tracking Status
b2g-v2.1 --- fixed

People

(Reporter: emorley, Assigned: hola)

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

b2g_ubuntu64_vm b2g-inbound opt test gaia-unit on 2014-08-14 06:24:23 PDT for push 1f538d44edbd

slave: tst-linux64-spot-466

https://tbpl.mozilla.org/php/getParsedLog.php?id=45935719&tree=B2g-Inbound

{
06:40:00     INFO -  gaia-unit-tests TEST-START | communications/contacts/test/unit/views/list_test.js | Facebook Contacts List
06:40:00     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List adding one FB Contact to an empty list
06:40:00     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List enter search mode
06:40:00     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List check empty search
06:40:00     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search by name and surname with trailing whitespaces
06:40:01     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search gets updated if contact changes
06:40:01     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search non-alphabetical characters
06:40:01     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search non-alphabetical characters with results
06:40:01     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search non-ASCII (accented characters) with ASCII results
06:40:01     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search ASCII (non-accented characters) with non-ASCII results
06:40:01     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search phone number
06:40:01     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search for empty contact
06:40:02     INFO -  gaia-unit-tests TEST-PASS  | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search for contacts with middle names
06:40:02     INFO -  JavaScript error: app://communications.gaiamobile.org/common/test/helper.js?time=1408023595437, line 31: expected false to be true
06:40:02     INFO -  gaia-unit-tests TEST-UNEXPECTED-FAIL | communications/contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search phrase highlightded correctly for first letter | Error: expected false to be true (app://communications.gaiamobile.org/common/test/helper.js?time=1408023595437:31)
06:40:02     INFO -  gaia-unit-tests INFO       | stack trace:
06:40:02     INFO -      Error: Error: expected false to be true (app://communications.gaiamobile.org/common/test/helper.js?time=1408023595437:31)
06:40:02     INFO -          at onerror (app://communications.gaiamobile.org/common/vendor/mocha/mocha.js:4959:10)
}
Summary: Intermittent ontacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search phrase highlightded correctly for first letter | Error: expected false to be true → Intermittent contacts/test/unit/views/list_test.js | Render contacts list Facebook Contacts List Search phrase highlightded correctly for first letter | Error: expected false to be true
I don't suppose you could take a look at this intermittent failure? This test was last touched in bug 1040881.
Flags: needinfo?(hola)
I haven't been able to reproduce locally. I'll test it more thoroughly as soon as I can, which I hope to happen tomorrow. Please, assign the bug to me, as I don't have privileges.
Flags: needinfo?(hola)
Thank you :-)
Assignee: nobody → hola
Attached file Pull request #23144
The problem seems to be fixed. I launched the tests a handful of times and it never failed.
Attachment #8476611 - Flags: review?(crdlc)
Comment on attachment 8476611 [details]
Pull request #23144

ok, thanks
Attachment #8476611 - Flags: review?(crdlc) → review+
Thanks for the fix!

master: https://github.com/mozilla-b2g/gaia/commit/2568263e8a89565ad84062f3af1c74f7e2ce02c9
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
It seems the problem is not fixed, Adrian, please could you have another look at it?

thanks
Status: RESOLVED → REOPENED
Flags: needinfo?(hola)
Resolution: FIXED → ---
The test failing is not related with the one that opened this bug, even though is in the same file. The test failing this time is:

Render contacts list ICE Contacts Display the ICE group if ICE contacts present - expected null to not equal null

I will take a look and let you know if I see something.
Flags: needinfo?(hola)
I haven't been able to reproduce the intermittent error. I think it could have been produced by a race condition, so in this pull request I modified it to check the test conditions within a calllback after the DOM is loaded. I would like to have feedback about this solution because since I haven't been able to reproduce, I don't know if this is the best solution, or even a solution at all.
Attachment #8489976 - Flags: feedback?(jmcf)
Comment on attachment 8489976 [details]
New Pull Request #24096

looks good to me. 

Please ask Francisco for a review, as he knows better than me that part of the code
Attachment #8489976 - Flags: feedback?(jmcf) → feedback+
Comment on attachment 8489976 [details]
New Pull Request #24096

I haven't been able to reproduce, and I think the error was provoked by a race condition, but I can't be sure. Could you take a look and tell us what you think? 

Thanks!
Attachment #8489976 - Flags: review?(francisco)
Hei Mike,

we still didn't go through the proper review here. Will start it now, hopefully we won't need to backout.
Flags: needinfo?(mhenretty)
Comment on attachment 8489976 [details]
New Pull Request #24096

Thanks Adrian
Attachment #8489976 - Flags: review?(francisco) → review+
landed:

https://github.com/mozilla-b2g/gaia/commit/b223a36889964fa186fe1494b6f9322c75f4652d
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Yeah, unfortunately if a different test in the same file fails, TBPL robot still thinks it's the same issue. Thanks for both fixes Adrian!

(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #84)
> Hei Mike,
> 
> we still didn't go through the proper review here. Will start it now,
> hopefully we won't need to backout.

Are you asking why I landed the first fix without proper peer review? That one was a unit test-only fix for a pretty bad intermittent, so I thought Christian's review was enough.
Flags: needinfo?(mhenretty)
You need to log in before you can comment on or make changes to this bug.