Closed Bug 1053976 Opened 5 years ago Closed 5 years ago

[B2G][E.me] Searching 'Social' does not display E.me apps

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified)

VERIFIED FIXED
2.1 S2 (15aug)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified

People

(Reporter: jschmitt, Assigned: kgrandon)

References

Details

(Keywords: regression, smoketest, Whiteboard: [systemfe])

Attachments

(3 files)

Attached file log.txt
Description:
Searching 'Social' in E.me doesn't display the hosted E.me apps and only shows 'Install' apps from Marketplace.

Repro Steps:
1) Update a Flame to 20140814040202
2) Connect to a Data/Wifi network
3) Select the search bar on the Homescreen
4) Search 'Social'

Actual:
No E.me apps are displayed when searching E.me

Expected:
E.me searches are populated with the E.me hosted apps.

Environmental Variables:
Device: Flame Master 319MB & 512MB
Build ID: 20140814040202
Gaia: 5e074831f9ddacdf6f622a6dffaecb626f740be8
Gecko: 5299864050ee
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes:
Repro frequency: 100%
See attached: screenshot, logcat
Attached image Everything_Me.png
Issue does NOT occur on 2.0 Flame 319MB & 512MB

The E.me 'Social' search populates correctly.

Environmental Variables:
Device: Flame 2.0 319MB & 512MB
Build ID: 20140814000201
Gaia: 8b1b64ca3347e015d7a57df6d053f95cd26046ca
Gecko: 2f288e8aea09
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
[Blocking Requested - why for this release]:
Regression and a Smoketest blocker.

Requesting a window.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ckreinbring
This looks to happen with all the other categories as well: Music and Games.
Regression window
Last working
BuildID: 20140813125055
Gaia: a2219a55145e730e56e09527b40152d68a43b0d9
Gecko: d7e78f0c1465
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First broken
BuildID: 20140814004506
Gaia: 5e074831f9ddacdf6f622a6dffaecb626f740be8
Gecko: de1d3c229e5a
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Working Gaia / Broken Gecko = No repro
Gaia: a2219a55145e730e56e09527b40152d68a43b0d9
Gecko: de1d3c229e5a
Broken Gaia / Working Gecko = Repro
Gaia: 5e074831f9ddacdf6f622a6dffaecb626f740be8
Gecko: d7e78f0c1465
Gaia push log: https://github.com/mozilla-b2g/gaia/compare/a2219a55145e730e56e09527b40152d68a43b0d9...5e074831f9ddacdf6f622a6dffaecb626f740be8


B2G-inbound
Last working
BuildID: 20140813130754
Gaia: 3c1312ea7ca995e077c64c3c626c59ce30f71196
Gecko: 9eb05ba8997d
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First broken
BuildID: 20140813131754
Gaia: 041babb2f2ecd426b909c7906d977d23f75de48f
Gecko: 5e0d4c1d7a7a
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Working Gaia / Broken Gecko = No repro
Gaia: 3c1312ea7ca995e077c64c3c626c59ce30f71196
Gecko: 5e0d4c1d7a7a
Broken Gaia / Working Gecko = Repro
Gaia: 041babb2f2ecd426b909c7906d977d23f75de48f
Gecko: 9eb05ba8997d
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/3c1312ea7ca995e077c64c3c626c59ce30f71196...041babb2f2ecd426b909c7906d977d23f75de48f
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by Bug 1041620 - Kevin - can you take a look?
Blocks: 1041620
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kgrandon)
Keywords: qaurgent
I think Kevin is slammed with CAF stuff right now.

Ben or Alive - Do you have cycles to help out here?
Flags: needinfo?(bfrancis)
Flags: needinfo?(alive)
Flags: needinfo?(alive)
Whiteboard: [systemfe]
I prefer systemfe guys on this issue, but if nobody could I will find someone to work on it.
Flags: needinfo?(anygregor)
About to jump on a flight, but I will get to this tomorrow if no one gets to this first. If it's not fixed tomorrow we will back out the regressing patch due to the smoketest failure. Sorry folks.
Adding qawanted for a retest. I'm having trouble reproducing this, and the info in the logs doesn't seem relevant - did we miss it?

If it's not working when you retest, can you also please open up a smart collection and check the contents of a collection? The APIs the search app and collection app uses is the same.

If it does work, then it's likely we hit some server issue from E.me.
Flags: needinfo?(kgrandon)
Keywords: qawanted
I've found some more information, this appears to be related to PRODUCTION profiles only. Removing the qawanted, sorry about that.
Keywords: qawanted
Attached file Github pull request
Swapping needinfos for a review. I imagine that we'll be doing some refactoring and moving of this logic out of places, and into newtab.js before 2.1 is over. I think we should probably land this asap to fix the smoketest blocker though.
Attachment #8473531 - Flags: review?(dale)
Attachment #8473531 - Flags: review?(bfrancis)
Flags: needinfo?(bfrancis)
Flags: needinfo?(anygregor)
Comment on attachment 8473531 [details] [review]
Github pull request

Yeah let's land this quick fix because it's causing other problems as well.
Attachment #8473531 - Flags: review?(dale)
Attachment #8473531 - Flags: review?(bfrancis)
Attachment #8473531 - Flags: review+
https://github.com/mozilla-b2g/gaia/commit/38a7563e677c927fca6a42a647332e2ebc3e8f9e
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → kgrandon
Target Milestone: --- → 2.1 S2 (15aug)
blocking-b2g: 2.1? → 2.1+
I am unable to reproduce this issue on the latest 2.1 Flame build:

Enviromental Variables:
----------------------------------------
Device: Flame 2.1 Master
BuildID: 20140815040204
Gaia: 9979fccc6321be72cd17370f3a20c65bc376af33
Gecko: c9f8cc9ce89c
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Verified as fixed.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Sorry, copy/paste error occured with comment #15

The correct variables are

Enviromental Variables:
----------------------------------------
Device: Flame 2.1 Master
BuildID: 20140818040201
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: 0aaa2d3d15cc
Version: 34.0a1 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.