Android 4.0 mochitest logs have "unable to execute gcc: No such file or directory" while building psutil, causing "bound method PandaTest.run_command of <__main__.PandaTest object at 0x22bfa10>> failed after 1 tries!

RESOLVED DUPLICATE of bug 1053197

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 1053197
4 years ago
4 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Test logs for Android 4.0 (for mochitests at least) include the following error output:

{
12:45:58     INFO -  Installing collected packages: psutil
[...SNIP...]
12:45:58     INFO -  building '_psutil_linux' extension
12:45:58     INFO -  creating build/temp.linux-x86_64-2.7
12:45:58     INFO -  creating build/temp.linux-x86_64-2.7/psutil
12:45:58     INFO -  gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -I/tools/python27/include/python2.7 -c psutil/_psutil_linux.c -o build/temp.linux-x86_64-2.7/psutil/_psutil_linux.o
12:45:58     INFO -  unable to execute gcc: No such file or directory
12:45:58     INFO -  error: command 'gcc' failed with exit status 1
12:45:58     INFO -  ----------------------------------------
[...SNIP...]
12:45:58     INFO - Return code: 1
12:45:58    ERROR - <bound method PandaTest.run_command of <__main__.PandaTest object at 0x2315a10>> failed after 1 tries!
}

The key failure there is "unable to execute gcc: No such file or directory", which I think means we don't have GCC available. We should either make sure we have gcc available, or not bother trying to compile packages like psutil.


(Side note: the "bound method PandaTest.run_command" error line gets confusingly highlighted at the top of the log, suggesting that it's involved in a test failure, even though it's not.)

Sample logs:
https://tbpl.mozilla.org/php/getParsedLog.php?id=45964059&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=45964802&tree=Mozilla-Inbound
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1053197
You need to log in before you can comment on or make changes to this bug.