table cell border doesn't get redrawn correctly when cell spans multiple rows

RESOLVED DUPLICATE of bug 105268

Status

()

RESOLVED DUPLICATE of bug 105268
17 years ago
17 years ago

People

(Reporter: willem, Assigned: karnaze)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
BuildID:    2001101703

The url above containes four small example tables.

When setting the browser window height to about 1/4th of the length of the 
page, and scrolling the page gradually by dragging the scroll bar slowly up and 
down (as opposed to clicking on the top of bottom of the scroll bar and 
scrolling a large amount):

The left and right border of the left cell, which spans 2 rows, gets only 
partially redrawn: only the part from the top until the bottom of the 
letter 'A' gets a left or right border, while the part of the left cell below 
the letter does not get a left or right border.

This happens in a seemingly random fashion: sometimes the border is complete, 
sometimes it's missing.

Reloading the page doesn't fix it.

However, scrolling a large amount by clicking on the top of bottom of the 
scroll bar will redraw the border correctly all the time.

(The url is also a test case for bug <http://bugzilla.mozilla.org/show_bug.cgi?
id=105403>: the bottom-border is missing in the second example).


Reproducible: Always
Steps to Reproduce:
1. Look at the url mentioned above.
2. Scroll page by small amounts up and down, and watch the border of the 'A' 
cells in the small tables


Actual Results:  Often, the left cell misses a part of its left or right border.

Expected Results:  The left and right border should be fully redrawn when/after 
scrolling.
tables
Assignee: jst → karnaze
Component: DOM Style → HTMLTables
QA Contact: ian → amar
(Reporter)

Comment 2

17 years ago
In case it wasn't clear from the description, the problem is with the first
("border"), third ("border-left") and fourth ("border-right") table on the page
from the url. Those tables specify for the left 'A' cell a vertical border.

The horizontal borders do get redrawn correctly, when scrolling vertically.
Confirming.  Doing this helps to confirm:

javascript:resizeTo(640,480)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 105268 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.