Fix places tests with promise rejection change

RESOLVED DUPLICATE of bug 1053809

Status

RESOLVED DUPLICATE of bug 1053809
4 years ago
4 years ago

People

(Reporter: jsantell, Assigned: jsantell)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

TEST-UNEXPECTED-FAIL | places/main.test bookmark-item-changed | There was an uncaught Promise rejection: JS frame :: resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///tmp/tmpRNb1bw.mozrunner/extensions/test-places@jetpack.xpi!/bootstrap.js -> resource://extensions.modules.test-places-at-jetpack.commonjs.path/toolkit/loader.js -> resource://extensions.modules.test-places-at-jetpack.commonjs.path/sdk/places/host/host-bookmarks.js :: createBookmarkItem :: line 93


Occuring due to test finishing before the createBookmarkItem would be finished, due to sdk/places/events observer events being synchronous
Created attachment 8473337 [details] [review]
GH PR 1587
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Attachment #8473337 - Flags: review?(evold)
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1053809
Comment on attachment 8473337 [details] [review]
GH PR 1587

might as well land the test comment change.
Attachment #8473337 - Flags: review?(evold) → review+
You need to log in before you can comment on or make changes to this bug.