_attachments path broken after staticfiles migration

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: yboniface, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
Users trying to download an addon from Thunderbird have a 404 since last push.

The reason is that Thunderbird goes through the '_attachments' path, which has a dedicated URL rule.

And we missed this one on the push.

Here is an example of URL going in 404:

https://addons.cdn.mozilla.net/user-media/addons/_attachments/54035/thunderbird_conversations-2.8.1-tb.xpi

And this is the fix we need, on this line (and two lines after):

https://github.com/mozilla-services/svcops-puppet/blob/master/modules/marketplace/templates/nginx/addons.conf#L43

change '_files/_attachments' to 'addons/_attachments'
(Reporter)

Comment 1

5 years ago
Note: I don't know why we add the 'Content-Disposition: attachment' header, I guess it's needed by Thunderbird.

In the case we think this is not anymore needed, we can then instead change in the code that we don't need that '_attachments' path anymore, and remove the dedicated URL rule. But I honestly don't know who can know that, so I think we should keep the path as it is.
The Content-Disposition: attachment header is, so that Thunderbird downloads are getting downloaded when you click the download button in Firefox. If you don't have that header, Firefox tries to install the xpi.
Duplicate of this bug: 1054174
Duplicate of this bug: 1054253
Duplicate of this bug: 1054258
Hmm, maybe not exact duplicates but more depending on this bug...
(Reporter)

Comment 7

5 years ago
I think duplicate it's fine, there is no specific action required on the other bugs other than the one here.

Thanks!
(Reporter)

Comment 8

5 years ago
Fix has been pushed https://github.com/mozilla-services/svcops-puppet/commit/e6703bc93693f51923ca4af843cfa2a36de10361
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.