JavaScript Error: "TypeError: this.app.element is null"

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: zcampbell, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
On device testing, the following error is present in logcat:

E/GeckoConsole( 4262): [JavaScript Error: "TypeError: this.app.element is null" {file: "app://system.gaiamobile.org/js/app_transition_controller.js" line: 324}]


The failure started with this b2g-inbound build:
https://tbpl.mozilla.org/?tree=B2g-Inbound&showall=1&rev=308aa5f9bc0e

and hence this Gaia commit:
https://github.com/mozilla-b2g/gaia/pull/22870


It is causing functional/UI automation failures and Eideticker test failures too.

We should back this out for test failures on device.


Replicated locally with:

Gaia      10e4b59fa2baba999e9d607acc244037c740fa55
Gecko     https://hg.mozilla.org/integration/b2g-inbound/rev/6741d405d54d
BuildID   20140815013215
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
(Reporter)

Comment 1

4 years ago
Greg, are you around still?
Flags: needinfo?(gweng)

Updated

4 years ago
Blocks: 920191
(Reporter)

Comment 2

4 years ago
Just let me double check the regression range before we back out anything.
Hmm...the patch passed tests on Gaia Try so I landed it, and the most strange thing is from the code I don't have any clue about why it would cause the error. However, if this is a regression, we can back it out and I would spend time on it.
Flags: needinfo?(gweng)
(Reporter)

Comment 4

4 years ago
This hasn't shown up on any desktopb2g tests, it's only on device.

Our device testing is getting it intermittently so I need a bit more time to track down a more accurate regression range.
(Reporter)

Comment 5

4 years ago
Dave generated a regression range from on-device automation:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=0b934bed627f&tochange=63c5f891c11a

I reverted:
https://github.com/mozilla-b2g/gaia/tree/e13cc05b6d615664d769e55b60754480848d076b

and ran the tests while observing the logcat. The error is only present with the above commit included.

Comment 6

4 years ago
(In reply to Zac C (:zac) from comment #5)
> I reverted:
> https://github.com/mozilla-b2g/gaia/tree/
> e13cc05b6d615664d769e55b60754480848d076b

Diff link:
https://github.com/mozilla-b2g/gaia/commit/e13cc05b6d615664d769e55b60754480848d076b
(Reporter)

Comment 7

4 years ago
edmorley, can we back that out on account of the test failures?
Flags: needinfo?(emorley)
Don't we need to open the original bug in case of backouts? Is this one fixed now due to the backout?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(In reply to Kevin Grandon :kgrandon from comment #9)
> Don't we need to open the original bug in case of backouts? Is this one
> fixed now due to the backout?

Yeah sorry completely forgot.
(Reporter)

Comment 11

4 years ago
I just noticed this is affecting v2.0 branch in the same way (I only just checked the results then).,

Ed can you do the same on v2.0? 

Thanks
Status: RESOLVED → REOPENED
Flags: needinfo?(emorley)
Resolution: FIXED → ---
Kevin cherrypicked the revert already (thank you :-)):
https://github.com/mozilla-b2g/gaia/commit/a5283446aab3d4e730973ed3fc1de69b7e874c08
Flags: needinfo?(emorley)
(Reporter)

Comment 13

4 years ago
Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
I just spoke to garndt over IRC about this, and apparently this is back after a re-landing of bug 1047645, this time with a different stack. I have a patch up on try and will land as soon as it clears. Sorry for the back-and-forth on this one, I'm having a bit of a tricky time to reproduce this locally.

This is the new error: JavascriptException: JavascriptException: TypeError: this.app.element is null
stacktrace:
@app://system.gaiamobile.org/js/app_transition_controller.js, line 147
Everything should be resolved now. Please let me know if you run into this issue again, and include the stack. Thanks!
So far I have not seen this issue come up in some of the builds that were failing.  Thanks for landing this so quickly.

I'll monitor it periodically over the weekend.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1054475
You need to log in before you can comment on or make changes to this bug.