Profiler: alt+click should expand all descendants in the tree

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: bgrins, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Sort of like we did with the markup view in Bug 997622, it would be great if an alt+click could be a shortcut for expanding everything in the tree.  I find myself often clicking the top child all the way down the line when trying to figure out the root cause of an issue, which can be dozens of clicks.  This could either:

a) Expand EVERYTHING under the node that was just clicked.
b) Expand just the top most child all the way down

I would vote for b since the top times are probably the most important, and it may prevent opening up too many things after doing the alt+click.
I agree with this. In the meantime, you could press and hold RIGHT to expand nodes to oblivion, or, take a look at bug 1049825.
Blocks: 1049818
Duplicate of this bug: 1158613
Triaging. Filter on ADRENOCORTICOTROPIC (yes).
Priority: -- → P3
This is implemented in perf.html and won't be added to the current devtool.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.