[Flame][KK] Cannot build Flame-kk build for 1.4 and 2.0 branch

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: njpark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
After cloning the B2G repo at git clone git://github.com/mozilla-b2g/B2G.git, using below commands to build flame-kk fails.
BRANCH=v2.0 ./config.sh flame-kk
BRANCH=v1.4 ./config.sh flame-kk


The error message is: 
fatal: manifest 'flame-kk.xml' not available
fatal: manifest flame-kk.xml not found
Repo sync failed
Is this likely to ever happen?
Flags: needinfo?(mwu)
(Reporter)

Comment 2

4 years ago
(In reply to Mike Habicher [:mikeh] from comment #1)
> Is this likely to ever happen?

I think William Hsu actually set up a build repo that builds 2.0 on flame kitkat.  This came up because we need to do regression check on 1.4 and 2.0.  Would be great if we can do this.
(Reporter)

Updated

4 years ago
Blocks: 1053781
(Reporter)

Comment 3

4 years ago
William, could you let us know how it was done to build 2.0?
Flags: needinfo?(whsu)

Comment 4

4 years ago
I am not the right person to do this.
Device team know the answer.


Hi, Viral,

Sorry. I cannot sure if you are the right person to handle this.
Do we have any plan to update manifest for Flame KK v2.0 and v1.4?
Thanks.
Flags: needinfo?(whsu) → needinfo?(vwang)

Comment 5

4 years ago
Since we can't flash system and userdata for flame KK now, I would like finish the full images porting first.
After we can provide the manifest.xml for full image, we will provide the manifest.xml for branch 1.4 and 2.0.
Flags: needinfo?(vwang)

Updated

4 years ago
Component: General → GonkIntegration

Comment 6

4 years ago
Agreed with viral - we should backport to 2.0 once we have full flashing working reasonably well.
Flags: needinfo?(mwu)
(In reply to viral [:viralwang] from comment #5)
> Since we can't flash system and userdata for flame KK now, I would like
> finish the full images porting first.
> After we can provide the manifest.xml for full image, we will provide the
> manifest.xml for branch 1.4 and 2.0.

viral, is there a bug that tracks the full image porting?
Flags: needinfo?(vwang)

Comment 8

4 years ago
we have bug 1054180 for full image porting, we already land the patches.
However, there's a sim card bug in bug 1052865, I think we should make sure we can detect the sim card first and create the manifest for different branch later
Flags: needinfo?(vwang)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.