Intermittent test_text.py TestText.test_will_simulate_a_key_up_when_entering_text_into_input_elements | TimeoutException: TimeoutException: Connection timed out

RESOLVED WORKSFORME

Status

Testing
Marionette
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({ateam-marionette-intermittent, intermittent-failure})

Trunk
ARM
Gonk (Firefox OS)
ateam-marionette-intermittent, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
b2g_emulator_vm mozilla-inbound opt test marionette-webapi on 2014-08-15 07:26:30 PDT for push 67e348e5f8dd

slave: tst-linux64-spot-738

https://tbpl.mozilla.org/php/getParsedLog.php?id=46037905&tree=Mozilla-Inbound

{
07:42:08     INFO -  08-15 10:36:01.076 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-START: /builds/slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit/test_text.py:test_will_simulate_a_key_up_when_entering_text_into_input_elements
07:42:08     INFO -  08-15 10:36:01.096 I/Gecko   (   44): 1408113361101	Marionette	INFO	sendToClient: {"from":"0","value":null}, {1f53e517-b317-4195-a8a2-4795b043eb8d}, {1f53e517-b317-4195-a8a2-4795b043eb8d}
07:42:08     INFO -  08-15 10:36:01.887 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://10.132.56.109:49273/javascriptPage.html" line: 0}]
07:42:08     INFO -  08-15 10:36:03.146 I/Gecko   (   44): 1408113363150	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {cbc55d3d-0cf9-48c1-a746-4ce6297ed8cc}, {cbc55d3d-0cf9-48c1-a746-4ce6297ed8cc}
07:42:08     INFO -  08-15 10:36:03.196 I/Gecko   (   44): 1408113363204	Marionette	INFO	sendToClient: {"from":"0","value":{"ELEMENT":"{790766fb-702e-4a40-af0d-b108e86b35c0}"}}, {d30af009-84db-4840-b1b3-9d228b5a7f53}, {d30af009-84db-4840-b1b3-9d228b5a7f53}
07:42:08     INFO -  08-15 10:36:05.226 I/Gecko   (   44): 1408113365228	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {996b1861-f901-4565-90e8-bf8cdb7b6d5d}, {996b1861-f901-4565-90e8-bf8cdb7b6d5d}
07:42:08     INFO -  08-15 10:36:05.326 I/Gecko   (   44): 1408113365326	Marionette	INFO	sendToClient: {"from":"0","value":{"ELEMENT":"{f0756099-03dc-4852-9cdf-6aa00e78d1d8}"}}, {73a409e8-6996-4239-a0c1-400bd1926dd4}, {73a409e8-6996-4239-a0c1-400bd1926dd4}
07:42:08     INFO -  08-15 10:36:05.627 I/Gecko   (   44): 1408113365635	Marionette	INFO	sendToClient: {"from":"0","value":"I like cheese"}, {e28b09d8-d5c5-4479-a720-bed0faf66217}, {e28b09d8-d5c5-4479-a720-bed0faf66217}
07:42:08     INFO -  08-15 10:36:06.176 I/Gecko   (   44): 1408113366185	Marionette	DEBUG	Got request: setContext, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140815062912","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"setContext","parameters":{"value":"content"}}, id: {f188b3dd-2863-4ea5-9846-b5e51d055bc1}
07:42:08     INFO -  08-15 10:36:06.186 I/Gecko   (   44): 1408113366188	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {f188b3dd-2863-4ea5-9846-b5e51d055bc1}, {f188b3dd-2863-4ea5-9846-b5e51d055bc1}
07:42:08     INFO -  08-15 10:36:06.246 I/Gecko   (   44): 1408113366248	Marionette	DEBUG	Got request: execute, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140815062912","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"executeScript","parameters":{"scriptTimeout":null,"specialPowers":false,"script":"log('TEST-END: /builds/slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit/test_text.py:test_will_simulate_a_key_up_when_entering_text_into_input_elements')","newSandbox":true,"args":[],"filename":"marionette_test.py","line":356}}, id: {cbba1052-2d23-4ee3-ab3f-d0496d9c8564}
07:42:08     INFO -  08-15 10:36:06.316 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-END: /builds/slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit/test_text.py:test_will_simulate_a_key_up_when_entering_text_into_input_elements
07:42:08     INFO -  08-15 10:36:06.346 I/Gecko   (   44): 1408113366346	Marionette	INFO	sendToClient: {"from":"0","value":null}, {cbba1052-2d23-4ee3-ab3f-d0496d9c8564}, {cbba1052-2d23-4ee3-ab3f-d0496d9c8564}
07:42:08     INFO -  B2G is still running but Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.
07:42:08    ERROR -  TEST-UNEXPECTED-ERROR | test_text.py TestText.test_will_simulate_a_key_up_when_entering_text_into_input_elements | TimeoutException: TimeoutException: Connection timed out
07:42:08     INFO -  Traceback (most recent call last):
07:42:08     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 199, in run
07:42:08     INFO -      self.tearDown()
07:42:08     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 357, in tearDown
07:42:08     INFO -      self.marionette.test_name = None
07:42:08     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 821, in test_name
07:42:08     INFO -      if self._send_message('setTestName', 'ok', value=test_name):
07:42:08     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/decorators.py", line 35, in _
07:42:08     INFO -      return func(*args, **kwargs)
07:42:08     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 617, in _send_message
07:42:08     INFO -      "Connection timed out", status=errors.ErrorCodes.TIMEOUT)
07:42:08     INFO -  TEST-INFO expected PASS | took 367817ms
}
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.