[Search] Visual Refinements for Rocket Bar Search Results screen

RESOLVED FIXED in 2.1 S4 (12sep)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: epang, Assigned: kgrandon)

Tracking

unspecified
2.1 S4 (12sep)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

(Whiteboard: [systemsfe])

User Story

https://mozilla.box.com/s/o9gbtnq3ttmfq2beoch6

Attachments

(1 attachment)

We're hoping to have 3 line labels in the search app for 2.1.  Also, there are some alignment changes which are covered in the spec.
No longer blocks: browser-chrome-mvp
Eric - I'm a bit confused, it seems that the attached spec only has 2 rows. Was this a spec for 2.0?

Do we have anything that illustrates 2.1, or should we attempt to increase it by ~1.4rem to accommodate the extra line of text?
Flags: needinfo?(epang)
Hey Kevin,

Sorry about that, the link was pulling the 2.0 spec.  Here's a link to the 2.1 spec
https://mozilla.box.com/s/o9gbtnq3ttmfq2beoch6

Thanks!
User Story: (updated)
Flags: needinfo?(epang) → needinfo?(kgrandon)
Great, thanks!
Flags: needinfo?(kgrandon)
Blocks: rocketbar-mvp
No longer blocks: rocketbar-search-mvp
Assignee: nobody → kgrandon
Posted file Github pull request
Cristian - would you mind helping me review this code that touches gaia-grid if you have time?
Attachment #8486879 - Flags: review?(crdlc)
Comment on attachment 8486879 [details] [review]
Github pull request

LGTM although there is a comment on github and I would like to add an unit test to test the method "gridItemHeight" with different values of text-rows (e.g. defined or not). Thanks a lot
Attachment #8486879 - Flags: review?(crdlc) → review+
Thanks Cristian. I fixed it up to increase height and allow the user to pass any number of rows for height. Also added a unit test.
Excellent!
Status: NEW → ASSIGNED
Master: https://github.com/mozilla-b2g/gaia/commit/bfe4a58d79f581f13faef18dd39c2a3b8c80cd0e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8486879 [details] [review]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): This is polish work for a feature.
[User impact] if declined: Search results (especially history results), are often truncated. This will help UX.
[Testing completed]: Manual and unit tests.
[Risk to taking this patch] (and alternatives if risky): The patch is fairly contained to this new polish work, so it should be no/low risk.
[String changes made]: None.
Attachment #8486879 - Flags: approval-gaia-v2.1?(fabrice)
Target Milestone: --- → 2.1 S4 (12sep)
Attachment #8486879 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.