If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][2.0][l10n][Settings] Scottish: The string Call Settings and Messaging Settings are truncated

RESOLVED DUPLICATE of bug 1055343

Status

Mozilla Localizations
gd / Scottish Gaelic
RESOLVED DUPLICATE of bug 1055343
3 years ago
2 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected)

Details

(Whiteboard: [l10n] [2.0-exploratory])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8473973 [details]
Call and Message Truncated

Description:
In Settings the string "Call Settings" and "Messaging Settings" are both truncated.

Repro Steps:
1) Update a Flame to 20140815000200
2) Set Language to Scottish - Gaidhlig
3) Select Settings
4) Observe that Call Settings and Messaging Settings are both truncated.

Actual: The text in the Call Settings and Messaging Settings are both truncated.

Expected: It is expected that the text for the Call Settings and Messaging Settings will not be truncated.
Environmental Variables:
Device: Flame 2.0 319(mb)
Build ID: 20140815000200
Gaia: 295c7f50707372e5af6d8e83148d2d970076dfd6
Gecko: 879c5208084f
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Keywords: Truncated Call Settings Message Scottish Gaelic Gaidhlig 

Repro frequency: 100%
See attached: Screenshot
(Reporter)

Comment 1

3 years ago
This issue DOES reproduce on Flame 1.4 319(mb)

Environmental Variables:
Device: Flame 1.4 319(mb)
Build ID: 20140815063005
Gaia: ab9a57d204c8c06cccc70cb7190da789fe17a3cb
Gecko: 3da3115ee33b
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Result: In Settings the string "Call Settings" and "Messaging Settings" are both truncated.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
Flags: needinfo?(ktucker)
Whiteboard: [l10n] [2.0-exploratory]

Comment 2

3 years ago
I appreciate all these bug reports about truncations but in general, I'm aware of these cases but there's nothing much I can do as I already said. So before filing a hundred truncation bugs, should be perhaps establish what can be done in general?
Hi Michael
We've already communicated a few times on dev.l10n about what to do in such cases. I'm sorry if you didn't get that.
Here are the UX guidelines that we had agreed upon sometime back: https://docs.google.com/document/d/16P56U6bSM1KVunkCG3WLmtH1cmhQf7YxT4mTPyWAnUw/edit
Just one thing: the doc says to use Ellipsis as last resort, but please don't!

There are many cases when we found that you could drop a word also, for example if you are in the Contacts menu and the header says "Add Contact", then you can drop the word Contact since you're already in that part of the app and it's clear to the user what it means.

Hope this helps. And sorry for the noise, we do realize that your strings are generally twice as long than in English, which is why there are so many instances of truncation!

Comment 4

3 years ago
Hi Delphine. Thanks for that but no, it doesn't help. Take the word 'Teachdaireachdan' for 'Messages' - it just IS the word for messages, I can't force it any shorter without causing huge linguistic problems.

Similarly, all these suggestions of dropping words, well, they're very Anglo-centric, English words well that way but in many languages you start sounding like a dork.

If the amount of space available and/or the font size is good as it's ever going to be, that is really really poor design from Mozilla, especially since Mozilla must have know before it started OS that different languages require more space than English. Including French...

It's not that I am unsympathetic to the need for concise languages but I already revisited these very obvious strings when I got my Geeksphone and saw a *lot* of truncations, so in terms of what's left, there really isn't anything *I* can do.
Ok then I guess the only solution you have is to close the bugs as WONTFIX for those where you can't find any kind of workaround.
Also, feel free to contact FirefoxOS UX team if you have any suggestions for them

Comment 6

3 years ago
I'm hesitant to just close them either as WONTFIX as I'd *like* to fix them. Is there someone from the UX team we could add to this bug to get some input? I'm sure the topic is relevant to other languages too. For one thing, I can't imagine zh not having a different font size setting for the entire locale because normally when you take a Latin font that looks ok at 12pt and substitute a Chinese font also using 12pt, nobody can read it because it's so small and you have to screw it up to 16pt or something at least.
Honestly I'm not aware of different font-size per locale.

Out of curiosity, is not possible to abbreviate words? For example  often I can't use "Impostazioni" for Settings, so I end up using "Impost.", "Impostaz." (or something drop the entire word, "Messages settings" -> "Messages", if the context is clear).

Comment 8

3 years ago
Some locales just don't do abbreviations or acronyms much or even hyphenation. My guess it's partly for historical reasons and partly for linguistic reasons. If I abbreviated Teachdaireachdan to Teachd. that would mean 'coming', if I abbreviated it to Teachdair. or Teachdaire. that would mean 'messenger' and I can't do Teachda. or Teachdaireac. because digraphs are inseperable in Gaelic i.e. I cannot break certain sequences such as ea, chd, ai etc etc.
(In reply to Michael Bauer from comment #8)
> Some locales just don't do abbreviations or acronyms much or even
> hyphenation. My guess it's partly for historical reasons and partly for
> linguistic reasons. If I abbreviated Teachdaireachdan to Teachd. that would
> mean 'coming', if I abbreviated it to Teachdair. or Teachdaire. that would
> mean 'messenger' and I can't do Teachda. or Teachdaireac. because digraphs
> are inseperable in Gaelic i.e. I cannot break certain sequences such as ea,
> chd, ai etc etc.

Thanks, that's exactly what I wanted to know.

Unfortunately I don't see many ways to solve this, especially considering how elements in Settings are structured. 
See for example bug 886409. For a lot of elements position is absolute, not relative to other elements. And I think this is going to bite us hard (see Flame showing the same content of Keon, when the screen resolution is much higher).

Comment 10

3 years ago
Well, I'm not a developer but surely it cannot be impossible to do something crafty that checks for truncation in the display and if there is truncation, it automatically reduces the font size down to a certain bottom line? No idea what the current size is, looks like 18pt and I'm sure it would read ok down to 12pt.
It's a bit left field but in WordPress you get all sorts of responsive themes these days which check your screen size and re-arrange the layout if your screen is below a certain size. Can't we do that for truncation?

Comment 11

3 years ago
NB this isn't just about some tiny locale having a problem. MozillaOS will look silly if anything but English (and even English) comes out with truncated strings all over the place or has more abbreviations than a UN dossier. It just makes the UI look like an afterthought.
(In reply to Michael Bauer from comment #10)
> Well, I'm not a developer but surely it cannot be impossible to do something
> crafty that checks for truncation in the display and if there is truncation,
> it automatically reduces the font size down to a certain bottom line? No
> idea what the current size is, looks like 18pt and I'm sure it would read ok
> down to 12pt.

It's already happening for the font used in headers starting from 2.0, but I don't think that's a possibility in Settings: the choice is between having menu items with different font-sizes (resize only long labels), or having short items with tiny font and unnecessary empty space (adapt all items to the same reduced font size).

IMO the best solution would be to leave the text wrap on at least two lines, but it's technically a nightmare for the way things are currently structured.

Comment 13

3 years ago
In which case I'll park the truncations outside the Settings for now and see what comes out of the woodwork. I think we're a long way off devices on the British market just now anyway.

As far as Settings goes - might sound crazy but how about running text? With that I mean that if the text is truncated, when the user scrolls down, the truncated line scrolls through till the end. That would keep it in one line, avoiding having to totally redesign, and still display all text without having to silly-shorten the strings and/or localizations?
We have suggested it in the past, not much success.
http://htmlpad.org/spacing/

Comment 15

3 years ago
Perhaps we should just file a bug and request implementation? Perhaps it just died off because English is not too badly affected but many l10n locales will be.
(In reply to Michael Bauer from comment #15)
> Perhaps we should just file a bug and request implementation? Perhaps it
> just died off because English is not too badly affected but many l10n
> locales will be.

English was affected only in Developer Settings (fixed on master).

You can try to file a bug in Gaia::Settings to reduce truncation of menu items, either by showing animated text or rearranging elements in the code. It would also help to explain why you need a solution (i.e. what you wrote in comment 8).

To be honest I fixed the Developer Settings because I was tired of seeing bugs filed and shortening strings to fit. Fixing Settings is too big of a task for me.

Comment 17

3 years ago
Filed Bug 1055343 we'll see what happens :/
Please add the truncation tracking bug in the blocks section.
Blocks: 1032262
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(jthomas)
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage+]

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(Reporter)

Updated

3 years ago
Flags: needinfo?(jthomas)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1055343
You need to log in before you can comment on or make changes to this bug.