Closed Bug 1054582 Opened 10 years ago Closed 10 years ago

"Send tab" offers to send tab to the device the tab is being sent from.

Categories

(Firefox for Android Graveyard :: Android Sync, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 977161

People

(Reporter: ckitching, Unassigned)

Details

For reasons that are not yet clear, "Send Tab" always gives me the option to send my tab to the device I'm sending the tab from (as well as real other devices).

What seems to be happening is we're fetching two devices from the database (the two you'd expect), but then our notion of "the guid of this device" doesn't match either of them, so we end up incorrectly displaying both to the user.

Whoops.
It turns out that each time you delete/re-add your Sync account a new ClientRecord is created with a new GUID, thus seeming to duplicate your device.

Since I'd recently done exactly this, it looks like what I'm reporting above is really an instance of that already-known problem (Bug 963446, Bug 977161, etc.)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.