quoteUrls() enters an infinite loop with a list of nonexistent bug ids to be linkified

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
Bugzilla-General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Koosha KM, Assigned: Koosha KM)

Tracking

({regression})

4.5.5
Bugzilla 5.0
regression
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8474100 [details] [diff] [review]
patch

Bug 213440 introduced linkification of a list of bug ids. If a list of nonexistent bug ids is in a comment, the 'while' loop will run forever because the string undergoes no change.

This is not the case with a list of nonexistent comment ids but we can change its code to be safer in future and to look more concise.
Attachment #8474100 - Flags: review?(glob)
(Assignee)

Updated

3 years ago
Assignee: general → koosha.khajeh
Comment on attachment 8474100 [details] [diff] [review]
patch

Review of attachment 8474100 [details] [diff] [review]:
-----------------------------------------------------------------

r=glob
Attachment #8474100 - Flags: review?(glob) → review+
Flags: approval?
Target Milestone: --- → Bugzilla 5.0

Updated

3 years ago
Flags: approval? → approval+
To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   dfcf306..0922b44  master -> master
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Depends on: 213440
Keywords: regression
You need to log in before you can comment on or make changes to this bug.