[Flame][KK]WiFi can only detect few available networks

RESOLVED WORKSFORME

Status

Firefox OS
Vendcom
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: mlien, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
[Device & Build]
  Flame KK build v165
---------------------------------------------
STR:
  1. Launch Settings app
  2. WiFi -> Verify number of available networks

Expected Result:
  Should list all available networks

Actual Result:
  Only show 3 networks (tpe office should have more than 6 available networks)
(Reporter)

Comment 1

3 years ago
verify again with v162-3 and v165 on same position and device, respectively
I reboot or turn Wi-Fi off then on to test detection result and find this might similar to bug1049393
v162-3 can reproduce detect few networks problem and reproduce rate is 3/10
v165 has higher reproduce rate as 6/10
See Also: → bug 1049393

Comment 2

3 years ago
(In reply to Mike Lien[:mlien] from comment #1)
> verify again with v162-3 and v165 on same position and device, respectively
> I reboot or turn Wi-Fi off then on to test detection result and find this
> might similar to bug1049393
> v162-3 can reproduce detect few networks problem and reproduce rate is 3/10
> v165 has higher reproduce rate as 6/10

yep, I think it means v162-3 and v165 have the same issue.

we've checked problem that when SSID string is invalid, this issue will happen.
pls help to check gecko/dom/wifi/WifiUtils.cpp‘WpaSupplicant::CheckBuffer modification

tks.

Comment 3

3 years ago
Use v165 base image and update gecko/gaia to v2.0.
After several times restart wifi, it looks like the number of available networks is normal.

However, bug 1049393 can be found easily, it still takes too much time to restart wifi.
(Reporter)

Comment 4

3 years ago
verify on Flame KK v166 only, still has this problem
wait pvt builds to update gaia/gecko for further verification
(Reporter)

Comment 5

3 years ago
verify with v180 + latest v2.0 gaia/gecko, it's fine
Gaia      91dd0e596aa7c124dd968e1474b23e7992dc35a1
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/a66168598533
BuildID   20140911220254
Version   32.0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.