Loading www.sidewalk.com crashes apprunner using 7/26/99 build

VERIFIED WORKSFORME

Status

defect
P3
normal
VERIFIED WORKSFORME
20 years ago
15 years ago

People

(Reporter: chriss, Assigned: danm.moz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

20 years ago
OS: NT4.0 service pack 5
Seamonkey build ID: 1999072608

Steps:
1) Launch apprunner
2) Type: www.sidewalk.com and hit return
3) As page loads, app crashes (note that a pop-up window is also opened)

I crashed 3 times in a row attempting to load. On the third attempt I got a blue
screen crash and what looked like a memory overflow error.

I also generated talkback reports - where do you read the ID?

Assigning to Beth in case this is already a dup.
Reporter

Updated

20 years ago
Whiteboard: chriss@netscape.com

Comment 1

20 years ago
well this page certainly has its share of bad coding, but it should not crash
the app. The JavaScript looks ok, there are several attributes that are illegal
or invalid. I can't say that this is a dup though. Chris, can you narrow this
one down to see which platforms it crashes on on hopefully figrie out what it is
that makes it crash?

Comment 3

20 years ago
Well, the crash happens on Mac  8.6, Win 95, Win NT, and Linux builds. The

problem seems to be caused by a combination of functions atht are being called in

SCRIPT element. I have narrowed down the code that seems to be responsible and

have attached it as a test case.

Updated

20 years ago
OS: other → All
Hardware: PC → All

Updated

20 years ago
Assignee: beppe → rickg
Component: Layout → Parser

Comment 4

20 years ago
Rick -- I've changed the owner to you and set the component to parser -- I'm not
sure where the crash is taking place and thought the parser would be a good
place to start. If I am totally wrong, just holler and tell me where I should
send this -- thanks

Comment 5

20 years ago
FYI: Was able to load the above URL and the attachment without crashing.
Verified with Aug 16th build.  Petersen, could you please verify this?
Thanx.

Comment 6

20 years ago
This crash problem seems to be fixed. However a new problem is occuring. When
loading the site , multiple popup windows will be displayed. Is this a new bug ?

Updated

20 years ago
Assignee: rickg → trudelle
Component: Parser → Browser-General

Comment 7

20 years ago
Peter -- this bug has mutated into something you should look into.

Updated

20 years ago
Assignee: trudelle → danm

Comment 8

20 years ago
Still crashes within a minute or so for me, using today's opt commercial bits on
Win98.  Don't know why we'd need to look at it, unless there is a window
problem.  Dan, could you take a look at this?
Assignee

Updated

20 years ago
Whiteboard: chriss@netscape.com → bad webshell in gfx text widget. wants more triage.
Assignee

Comment 9

20 years ago
The crash happens reliably in a debug build (in which accessing deleted objects is much more
dangerous), as the loading of a new style sheet causes frames to be reconstructed.  It looks like
the webshell within some gfx text widget is being torn down badly.  The other problem mentioned
above, that a bunch of new windows are being generated, I've moved to bug 15737.
  Keeping for now, until I figure out who really wants this bug.
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME
Whiteboard: bad webshell in gfx text widget. wants more triage.
Target Milestone: M11
Assignee

Comment 10

20 years ago
But, I had no trouble loading this page with today's build. Seems like someone fixed the problem
in my absence.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 11

20 years ago
With the Nov 15th build (1999111508), the url loads properly.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.