Copy/paste not working consistently in Google Docs

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
3 years ago
2 years ago

People

(Reporter: Reinier Kaper, Unassigned)

Tracking

31 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

Steps to reproduce:

This is on Mac OS Mavericks (haven't tested any other platforms).

1. I created a new Google Document (regular Document) and added some lorem ipsum paragraphs to it (copied from Sublime Text, so no hidden XML or anything).

2. I selected an arbitrary part of text and copied with COMMAND+C.


Actual results:

Results vary. _Most_ of the time nothing happens (e..g the text doesn't get copied, nor do I see the quick "Edit" highlight in Mac OS which indicates a copy command has been executed).

Some times the selected text actually gets copied, but this only works once. E.g. pressing COMMAND+C multiple times will never result in additionally copying the selected text.

If this is an "optimization", then it's completely unnecessary.

It seems like selecting an other part of text _sometimes_ enables me to copy again, but this is completely random.


Expected results:

The text should have copied.

Comment 1

3 years ago
I can reproduce the problem in Nightly34.0a1, and also Firefox24esr and IE11 on windows7.
I cannot reproduce the problem in   only   Google Chrome....

Comment 2

3 years ago
FWIW, I can't reproduce on either 32 or 34, on OS X. Seems like a google docs problem?

Comment 3

3 years ago
STR

1. Created a new Google Document
2. Type several words
3. Select text[1] Ctrl+C [1]
4. Select other text[2] Ctrl+C 
5. Paste to elsewhere/other application

Actual Results:
text[1] is pasted

Expected Results:
text[2] should be pasted

Comment 4

3 years ago
(In reply to Alice0775 White from comment #3)
> STR
> 
> 1. Created a new Google Document
> 2. Type several words
> 3. Select text[1] Ctrl+C [1]
> 4. Select other text[2] Ctrl+C 
> 5. Paste to elsewhere/other application
> 
> Actual Results:
> text[1] is pasted
> 
> Expected Results:
> text[2] should be pasted

I could reproduce this the first time I tried, but after selecting text a third, fourth or nth time, it worked again. :-\

If it's also broken in IE, I would be very surprised if it was our bug rather than Google's... To figure this out with more certainty would require someone deep-diving in the google docs code, and I don't have the time to do this right now.

I'll say this though: the fact that the menu isn't highlighting on OS X basically means that the shortcut isn't getting to us, which means that google docs is stealing the keydown/keypress and the shortcut therefore doesn't work. That would be bug 380637, bug 1052569 and friends - but bug 1052569 seems headed in the direction of allowing the web page to implement its own copy/paste support and therefore allowing those shortcuts to be overridden, which makes this entirely google's issue.

Comment 5

2 years ago
Build ID 	20160105164030
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:43.0) Gecko/20100101 Firefox/43.0

Build ID 	20160106030225
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:46.0) Gecko/20100101 Firefox/46.0

Hi,

I can't reproduce this bug on Mac OS X 10.10 with FF Nightly 46.0a1 and FF 43 following the steps from Comment 3, for me it works, the second text is pasted. Based on the fact that this problem was reported and tested in versions 31, 32, 34, Reinier can you retest this with a new version of Firefox. Please update your version to version 43 or you can use this link: https://www.mozilla.org/en-US/firefox/desktop/ and retest this issue.
Thank you
Flags: needinfo?(rp.kaper+mozilla)

Comment 6

2 years ago
Hi,
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
Reporter, please feel free to reopen it if you are still having this issue on the latest Firefox version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(rp.kaper+mozilla)
Resolution: --- → INCOMPLETE

Comment 7

2 years ago
I was asked to test this again 1.5 years after reporting it.
I no longer have access to the same environment, so I can't help you out.
You need to log in before you can comment on or make changes to this bug.