Intermittent test_dsds_numRadioInterfaces.js | TimeoutException: TimeoutException: Connection timed out

RESOLVED WORKSFORME

Status

Firefox OS
RIL
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
b2g_emulator_vm b2g-inbound opt test marionette-webapi on 2014-08-18 06:36:22 PDT for push 14e946f04d3e

slave: tst-linux64-spot-612

https://tbpl.mozilla.org/php/getParsedLog.php?id=46168755&tree=B2g-Inbound

{
07:26:15     INFO -  08-18 10:20:08.173 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-START: /builds/slave/test/build/tests/marionette/tests/dom/system/gonk/tests/marionette/test_screen_state.js
07:26:15     INFO -  08-18 10:20:08.223 I/Gecko   (   44): 1408371608224	Marionette	INFO	sendToClient: {"from":"0","value":null}, {b99ec3b8-4463-4124-a3e0-d66ccb2f246e}, {b99ec3b8-4463-4124-a3e0-d66ccb2f246e}
07:26:15     INFO -  08-18 10:20:09.063 E/GeckoConsole(   44): [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,<html>test%20page</html>" line: 0}]
07:26:15     INFO -  08-18 10:20:09.644 I/Gecko   (   44): 1408371609650	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {83524246-077b-4454-9449-0262dd570acf}, {83524246-077b-4454-9449-0262dd570acf}
07:26:15     INFO -  08-18 10:20:09.744 I/Gecko   (   44): 1408371609747	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {14580891-5191-4098-889a-adaac898a6c8}, {14580891-5191-4098-889a-adaac898a6c8}
07:26:15     INFO -  08-18 10:20:10.874 I/Gecko   (   44): 1408371610872	Marionette	INFO	sendToClient: {"emulator_cmd":"gsm report creg","id":872}, -1, {41fed72a-a142-42c3-8fa9-d446ba2edf23}
07:26:15     INFO -  08-18 10:20:10.904 I/Gecko   (   44): MARIONETTE TEST RESULT:TEST-PASS | test_screen_state.js | 'gsm report creg' successful - OK should equal OK
07:26:15     INFO -  08-18 10:20:10.904 I/Gecko   (   44): MARIONETTE TEST RESULT:TEST-PASS | test_screen_state.js | screen is disabled - true was true, expected true
07:26:15     INFO -  08-18 10:20:11.944 I/Gecko   (   44): 1408371611944	Marionette	INFO	sendToClient: {"emulator_cmd":"gsm report creg","id":873}, -1, {41fed72a-a142-42c3-8fa9-d446ba2edf23}
07:26:15     INFO -  08-18 10:20:11.964 I/Gecko   (   44): MARIONETTE TEST RESULT:TEST-PASS | test_screen_state.js | 'gsm report creg' successful - OK should equal OK
07:26:15     INFO -  08-18 10:20:11.964 I/Gecko   (   44): MARIONETTE TEST RESULT:TEST-PASS | test_screen_state.js | screen is enabled - true was true, expected true
07:26:15     INFO -  08-18 10:20:11.984 I/Gecko   (   44): 1408371611984	Marionette	INFO	sendToClient: {"from":"0","value":{"passed":4,"failures":[],"expectedFailures":[],"unexpectedSuccesses":[]}}, {41fed72a-a142-42c3-8fa9-d446ba2edf23}, {41fed72a-a142-42c3-8fa9-d446ba2edf23}
07:26:15     INFO -  08-18 10:20:12.043 I/Gecko   (   44): 1408371612046	Marionette	DEBUG	Got request: execute, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140818062215","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"executeScript","parameters":{"scriptTimeout":null,"specialPowers":false,"script":"log('TEST-END: /builds/slave/test/build/tests/marionette/tests/dom/system/gonk/tests/marionette/test_screen_state.js');","newSandbox":true,"args":[],"filename":"marionette_test.py","line":541}}, id: {aac81456-5af1-4a26-bf12-3ea25f30b3f8}
07:26:15     INFO -  08-18 10:20:12.073 I/Gecko   (   44): MARIONETTE LOG: INFO: TEST-END: /builds/slave/test/build/tests/marionette/tests/dom/system/gonk/tests/marionette/test_screen_state.js
07:26:15     INFO -  08-18 10:20:12.103 I/Gecko   (   44): 1408371612104	Marionette	INFO	sendToClient: {"from":"0","value":null}, {aac81456-5af1-4a26-bf12-3ea25f30b3f8}, {aac81456-5af1-4a26-bf12-3ea25f30b3f8}
07:26:15     INFO -  08-18 10:20:12.123 I/Gecko   (   44): 1408371612127	Marionette	DEBUG	Got request: setTestName, data: {"to":"0","sessionId":{"rotatable":true,"browserVersion":"34.0a1","takesScreenshot":true,"appBuildId":"20140818062215","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","secureSsl":false,"platform":"ANDROID","browserName":"B2G","version":"34.0a1","device":"qemu","b2g":true,"nativeEvents":false,"platformVersion":"34.0a1","takesElementScreenshot":true,"platformName":"ANDROID","handlesAlerts":false},"name":"setTestName","parameters":{"value":null}}, id: {0c7828dd-07a9-4af5-8a69-d78ddc6d8c3d}
07:26:15     INFO -  08-18 10:20:12.133 I/Gecko   (   44): 1408371612137	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {0c7828dd-07a9-4af5-8a69-d78ddc6d8c3d}, {0c7828dd-07a9-4af5-8a69-d78ddc6d8c3d}
07:26:15     INFO -  08-18 10:20:12.163 I/Gecko   (   44): 1408371612168	Marionette	INFO	sendToClient: {"from":"0","value":[["INFO","TEST-START: /builds/slave/test/build/tests/marionette/tests/dom/system/gonk/tests/marionette/test_screen_state.js","Mon Aug 18 2014 10:20:08 GMT-0400 (EDT)"],["INFO","TEST-END: /builds/slave/test/build/tests/marionette/tests/dom/system/gonk/tests/marionette/test_screen_state.js","Mon Aug 18 2014 10:20:12 GMT-0400 (EDT)"]]}, {2ba6b763-dd19-4192-af3a-9e19e8a3b262}, {2ba6b763-dd19-4192-af3a-9e19e8a3b262}
07:26:15     INFO -  08-18 10:20:12.224 I/Gecko   (   44): 1408371612232	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {7b390136-90e0-4db8-98ec-6f949754e224}, {7b390136-90e0-4db8-98ec-6f949754e224}
07:26:15     INFO -  08-18 10:20:13.494 I/Gecko   (   44): 1408371613500	Marionette	DEBUG	accepted connection on 127.0.0.1:41635
07:26:15     INFO -  08-18 10:20:13.674 I/Gecko   (   44): 1408371613679	Marionette	INFO	could not load listener into content for page: chrome://b2g/content/shell.html
07:26:15     INFO -  08-18 10:20:13.694 I/Gecko   (   44): 1408371613699	Marionette	INFO	sendToClient: {"from":"0","value":{"browserName":"B2G","browserVersion":"34.0a1","platformName":"ANDROID","platformVersion":"34.0a1","handlesAlerts":false,"nativeEvents":false,"rotatable":true,"secureSsl":false,"takesElementScreenshot":true,"takesScreenshot":true,"platform":"ANDROID","XULappId":"{3c2e2abc-06d4-11e1-ac3b-374f68613e61}","appBuildId":"20140818062215","device":"qemu","version":"34.0a1","b2g":true}}, {0d0b2e0b-5810-4344-b8c3-9569c83b9a9e}, {0d0b2e0b-5810-4344-b8c3-9569c83b9a9e}
07:26:15     INFO -  08-18 10:20:13.804 I/Gecko   (   44): 1408371613803	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {4936b49b-d3ac-4eb2-8774-a1f68513ae67}, {4936b49b-d3ac-4eb2-8774-a1f68513ae67}
07:26:15     INFO -  B2G is still running but Marionette can't respond due to either a Gecko, Gaia or Marionette error. Above, the 5 most recent errors are listed. Check logcat for all errors if these errors are not the cause of the failure.
07:26:15    ERROR -  TEST-UNEXPECTED-ERROR | test_dsds_numRadioInterfaces.js | TimeoutException: TimeoutException: Connection timed out
07:26:15     INFO -  Traceback (most recent call last):
07:26:15     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 171, in run
07:26:15     INFO -      testMethod()
07:26:15     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 408, in runTest
07:26:15     INFO -      self.marionette.test_name = os.path.basename(self.jsFile)
07:26:15     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 821, in test_name
07:26:15     INFO -      if self._send_message('setTestName', 'ok', value=test_name):
07:26:15     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/decorators.py", line 35, in _
07:26:15     INFO -      return func(*args, **kwargs)
07:26:15     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 617, in _send_message
07:26:15     INFO -      "Connection timed out", status=errors.ErrorCodes.TIMEOUT)
07:26:15     INFO -  TEST-INFO expected PASS | took 362043ms
}
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.