FTP time/date data incorrect

VERIFIED FIXED in M14

Status

()

Core
Networking
P3
trivial
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: Crysgem, Assigned: Judson Valeski)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+], URL)

(Reporter)

Description

19 years ago
Apprunner Build ID: 1999072608

The... timestamps?... of the directories are some 4 hours en retard (as
compared with the display of Enforcer 5.0 and Ancestor 4.6); as if displaying
the PST hour...?

Comment 1

19 years ago
I believe timestamps are server generated. Perhaps the other software corrects
values. If that is the case an enhancement bug should be filed.

Updated

19 years ago
Assignee: don → gagan
Component: Browser-General → Necko

Updated

19 years ago
Assignee: gagan → valeski
Target Milestone: M10

Comment 2

19 years ago
ftp = Jud

Updated

19 years ago
Blocks: 12834

Updated

19 years ago
No longer blocks: 12834

Updated

19 years ago
QA Contact: leger → paulmac

Comment 3

19 years ago
Updating QA Contact
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M14
(Assignee)

Comment 4

19 years ago
This is server dependent. FTP servers decide what GMT offset and timezone they
will stamp times with. FTP clients can only *assume* what the servers are using.
Currently we assume the server is GMT.

Updated

19 years ago
Blocks: 12834
(Assignee)

Comment 5

19 years ago
*** Bug 20706 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=20706 seems to be making a different
point.  20706 says teh _date_ is incorrect, 10551 says teh time is incorrect.  I
noticed that if I browse to the nightly build ftp directory the date for the
latest win32 build is displayed as 11/30.  This is not a GMT offset issue I
don't think.  Are these two seperate bugs.
(Assignee)

Comment 7

19 years ago
*** Bug 21281 has been marked as a duplicate of this bug. ***

Updated

19 years ago
OS: Windows 98 → All
Hardware: PC → All
Summary: FTP time data incorrect → FTP time/date data incorrect

Comment 8

19 years ago
adding "date" to summary per dups.
I see this on Linux too, marking all.

Comment 9

18 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
(Reporter)

Comment 10

18 years ago
As I humbly judge the loaded results of the cited URL, the dates returned are no
longer inaccurate; only the hours now differ (upon the MICROSOFT WINDOWS 98
1999122308 build).

Comment 11

18 years ago
when I go to ftp://ftp.mozilla.org I get dates that are off by a year (10/29/00
rather than 10/29/99)

With 5.0, the year shows with 99

Comment 12

18 years ago
/pub/mozilla/nightly/latest right now lists...
NS 4.7:
  mozilla-i686-pc-linux-gnu....  5402 Kb    Thu Jan  6 09:02:00 2000 Unix Tape
Archive

Mozilla 2000.01.04.09 Linux:
mozilla-i686-pc-linux-gnu.tar.gz  5532430  01/01/00 11:18:00 am
(Assignee)

Updated

18 years ago
Keywords: beta1

Comment 13

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
(Assignee)

Comment 14

18 years ago
fix checked in. do not use 4.x to for date comparison if you're testing 
dirs/files with dates anywhere between now and Jan 1 1999. 4.x has a y2k bug.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
this looks nailed down now. confirmed by telnetting to various sites and
comparing last modified times to those that show on ftp listings

marking verified with 2/9 builds, go jud!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.