netwerk/ipc/RemoteOpenFileChild.cpp:84:68: error: 'dup' was not declared in this scope

RESOLVED FIXED in Firefox 33

Status

()

Core
Networking: File
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Jan Beich, Assigned: Jan Beich)

Tracking

Trunk
mozilla34
All
FreeBSD
Points:
---

Firefox Tracking Flags

(firefox33 fixed, firefox34 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
It doesn't happen with unified build because NeckoParent.cpp in the same compilation unit pulls <unistd.h> from FileUtils.h (via ContentParent.h).

netwerk/ipc/RemoteOpenFileChild.cpp:84:19: error: use of undeclared identifier 'dup'
    PROsfd osfd = dup(PR_FileDesc2NativeHandle(other.mNSPRFileDesc));
                  ^
netwerk/ipc/RemoteOpenFileChild.cpp:393:17: error: use of undeclared identifier 'dup'
  PROsfd osfd = dup(PR_FileDesc2NativeHandle(mNSPRFileDesc));
                ^
(Assignee)

Comment 2

4 years ago
Created attachment 8474703 [details] [diff] [review]
fix

Explicitly add unistd.h like in RemoteOpenFileParent.cpp.

https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=a290add459d9
Attachment #8474703 - Flags: review?(swu)
(Assignee)

Comment 3

4 years ago
Comment on attachment 8474703 [details] [diff] [review]
fix

Approval Request Comment
[Feature/regressing bug #]: bug 988816 regression
[User impact if declined]: broken build on at least FreeBSD without --enable-unified-compilation
[Describe test coverage new/current, TBPL]: soon
[Risks and why]: Low, broken build at most.
[String/UUID change made/needed]: None
Attachment #8474703 - Flags: approval-mozilla-beta?
Attachment #8474703 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
Attachment #8474703 - Flags: approval-mozilla-beta?

Comment 4

4 years ago
Comment on attachment 8474703 [details] [diff] [review]
fix

Review of attachment 8474703 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.  It looks good to me, and I think we also need it get signed by Jason.
Attachment #8474703 - Flags: review?(swu)
Attachment #8474703 - Flags: review?(jduell.mcbugs)
Attachment #8474703 - Flags: review+
(Assignee)

Comment 5

4 years ago
(In reply to Jan Beich from comment #2)
> https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=a290add459d9
> gfx/thebes/gfxPattern.cpp:61:13: error: 'Filter' is not a class, namespace, or enumeration

Oops, unrelated red due to bug 1053159. Trying again with fresh m-i changes.

https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=aec5ea0efe64
Attachment #8474703 - Flags: review?(jduell.mcbugs) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb91698edd20
Assignee: nobody → jbeich
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/bb91698edd20
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
status-firefox33: --- → affected
status-firefox34: --- → fixed
Attachment #8474703 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
approval-mozilla-aurora+ is enough to get the sheriff attention ;)
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.