[B2G][Window Mgmt][Downloads] When the user attempt a failed download, the download failed icon does not appear

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: Petes, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected)

Details

(Whiteboard: [2.1-flame-test-run-1] )

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8474742 [details]
fd.txt

Description:
When the user attempt a failed download, the download failed icon on left does not appear 

Repro Steps:
1) Update a Flame to 20140818040201
2) Enable USB
3) Go to the Browser > http://owd.tid.es/dm/
4) Download a file

Actual:
download failed icon does not display 

Expected:
download failed icon display 

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140818040201
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: 0aaa2d3d15cc
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 3/3 - 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13535/
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8474748 [details]
2014-08-18-13-12-50.png
(Reporter)

Comment 2

4 years ago
This issue also reproduces on the Flame 2.1 (512mb), the download failed icon does not display 

Flame 2.1

Environmental Variables:
Device: Flame Master (512mb)
BuildID: 20140818040201
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: 0aaa2d3d15cc
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

________________________________________________________________________________________________________________________

This issue does not reproduce on the Flame 2.0 (319mb), the download failed icon display  

Flame 2.0

Device: Flame 2.0 (319mb)
BuildID: 20140818000201
Gaia: fb2dd31abed2803eb7ad67eb4c52abb48de1e0f7
Gecko: 09f7a7184c71
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 3

4 years ago
This issue also reproduces on the Buri 2.1, the download failed icon does not display 

Buri 2.1

Environmental Variables:
Device: Buri 2.1 Master
BuildID: 20140818073016
Gaia: ba1992f2addc5a84afc2eab426f222a6bf2962ba
Gecko: bf27e27c994d
Version: 34.0a1 (2.1 Master)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

________________________________________________________________________________________________________________________

This issue does not reproduce on the Buir 2.0, Buri 1.4. The download failed icon display  

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140818063008
Gaia: 640ce38ca03f1e26a4524ff4215b8b3f7731e2f0
Gecko: 692c93509dc9
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Buri 1.4
BuildID: 20140818063007
Gaia: 21bec64497dc06a7f12071d573570ba8fea598ae
Gecko: 07d78d0f9bef
Version: 30.0 (1.4)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
This might be a dupe of bug 1055199

Same root cause?

This is a regression from 2.0 but seems minor. Not nominating to block.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
Component: Gaia::System::Window Mgmt → Gaia::System

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 5

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.