Packaged apps fail to load in es due to [JavaScript Error: "TypeError: window.navigator.l10n is undefined"

VERIFIED FIXED

Status

Marketplace
General
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: krupa, Assigned: ngoke)

Tracking

x86
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

4 years ago
Connectivity: wifi with data roaming enabled
SIM used: Movistar SIM
Gaia/device: hamachi/1.4(30.0; 2014-08-16;21bec644)eng build


steps to reproduce:
1. Set language on your firefoxOS device to es
2. Launch marketplace-dev packaged app
3. Change language on phone to en-US
4. Repeat step #2


expected behavior:
Packaged app loads fine irrespective of the lang on the device.

actual behavior:
Packaged (dev, stage and feed-dev) apps load fine if lang is set to en-US but fail to load if lang is set to es on the device



08-18 14:57:28.379 E/GeckoConsole(  657): Content JS LOG at app://packaged.marketplace-dev.allizom.org/media/js/include.js:6 in anonymous: Mozilla(R) FP-MKT (R) 1.0
08-18 14:57:28.379 E/GeckoConsole(  657): Content JS LOG at app://packaged.marketplace-dev.allizom.org/media/js/include.js:6 in anonymous:    (C)Copyright Mozilla Corp 1998-2014
08-18 14:57:28.389 E/GeckoConsole(  657): Content JS LOG at app://packaged.marketplace-dev.allizom.org/media/js/include.js:6 in anonymous: 
08-18 14:57:28.389 E/GeckoConsole(  657): Content JS LOG at app://packaged.marketplace-dev.allizom.org/media/js/include.js:6 in anonymous: 64K High Memory Area is available.
08-18 14:57:28.729 E/GeckoConsole(  657): [JavaScript Error: "TypeError: window.navigator.l10n is undefined" {file: "app://packaged.marketplace-dev.allizom.org/media/js/include.js" line: 5}]
08-18 14:57:28.749 E/GeckoConsole(  657): Content JS LOG at app://packaged.marketplace-dev.allizom.org/media/js/include.js:7 in u/<: [user] Saving settings to localStorage
08-18 14:57:28.759 E/GeckoConsole(  657): Content JS LOG at app://packaged.marketplace-dev.allizom.org/media/js/include.js:7 in u/<: [urls] Using settings.media_url: https://marketplace-dev.mozflare.net/media/
08-18 14:57:28.759 E/GeckoConsole(  657): Content JS LOG at app://packaged.marketplace-dev.allizom.org/media/js/include.js:7 in u/<: [urls] Changed settings.cdn_url: https://marketplace-dev.mozflare.net
(Assignee)

Comment 1

4 years ago
https://github.com/mozilla/fireplace/commit/0272034d1cbd8e72552297cb1ddae4eef9137300
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

4 years ago
verified fixed.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Assignee: nobody → kngo
You need to log in before you can comment on or make changes to this bug.