If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ConfirmAccount extension not working in Mozilla Wiki dev (1.23)

VERIFIED FIXED

Status

Infrastructure & Operations
WebOps: IT-Managed Tools
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ckoehler, Assigned: cyliang)

Tracking

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/773] , URL)

(Reporter)

Description

3 years ago
https://wiki-dev.allizom.org/Special:RequestAccount
Mozilla Wiki dev instance has been upgraded to MediaWiki 1.23 and the ConfirmAccount extension is not working. 

Special:RequestAccount display a blank page. 

Steps to reproduce:

1. Visit main page of wiki: https://wiki-dev.allizom.org/
2. Click "login/create account"
3. Click "request one"

Expected outcome:

User is able to request a new account at Special:RequestAccount

Actual outcome:

User sees a blank screen.

This is a pretty significant blocker to rolling out the update to Stage and Prod since it prevents new users from creating accounts.

Updated

3 years ago
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/773]
https://www.mediawiki.org/wiki/Manual:Errors_and_symptoms#You_see_a_Blank_Page
(Assignee)

Updated

3 years ago
Assignee: server-ops-webops → cliang
(Assignee)

Comment 2

3 years ago
Tailing out /var/log/php_errors.log, I saw the following error when trying to request an account:

[19-Aug-2014 08:01:11] PHP Fatal error:  Call to undefined method WebRequest::getFileSize() in /data/www/wiki-dev.allizom.org/wiki/extensions/ConfirmAccount/frontend/specialpages/actions/RequestAccount_body.php on line 318

After updating the extension to 1.23, it looks like the page is displaying.  However, when I attempt to submit an account request, I'm getting "A database query error has occurred. This may indicate a bug in the software."  

Doing some more debugging ....
(Assignee)

Comment 3

3 years ago
Looks like I had to run the maintenance/update.php script to get things sorted out.  I was able to submit an account request.  Please re-open this bug if the account request did not make it through.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

3 years ago
Looks good, thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.