[e10s] Enable devtools/styleeditor tests

RESOLVED FIXED in Firefox 46

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: bgrins, Assigned: bgrins)

Tracking

(Blocks 1 bug)

Trunk
Firefox 46
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox46 fixed)

Details

(Whiteboard: [e10s-m7])

Attachments

(4 attachments, 1 obsolete attachment)

Assignee

Description

5 years ago
No description provided.
Assignee

Comment 1

5 years ago
Running tests with mochitest-devtools --e10s browser/devtools/styleeditor/
Assignee

Comment 2

5 years ago
Part 1 - amazingly only one test seems to be failing when running with e10s, so this moves the skip-if condition to only that test.  Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=2afacad9bccc
Attachment #8474880 - Flags: review?(fayearthur)
Comment on attachment 8474880 [details] [diff] [review]
styleeditor-e10s-pt1.patch

Looks good if try's good.
Attachment #8474880 - Flags: review?(fayearthur) → review+
Assignee

Updated

5 years ago
Keywords: leave-open
Assignee

Comment 4

5 years ago
Looks like there was an unrelated failure on the try push - here's a new one: https://tbpl.mozilla.org/?tree=Try&rev=610e9cf274cf
Assignee

Updated

5 years ago
Keywords: checkin-needed

Updated

5 years ago
tracking-e10s: --- → +
Assignee

Updated

5 years ago
Blocks: 1058875
Assignee

Comment 7

5 years ago
I'm seeing quite a few other failures on Holly (https://tbpl.mozilla.org/?tree=Holly), like this: https://tbpl.mozilla.org/php/getParsedLog.php?id=46485165&full=1&branch=holly#error87.

Though many of them seem to be possibly caused by an error during toolbox destroy that oddly doesn't seem to be an issue with the other test suites):

10:29:35     INFO -  3977 INFO TypeError: this.webconsolePanel is undefined: Toolbox.prototype._saveSplitConsoleHeight@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/toolbox.js:367:1
10:29:35     INFO -  3978 INFO Toolbox.prototype.destroy@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/toolbox.js:1367:5
10:29:35     INFO -  3979 INFO EventEmitter_emit@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/event-emitter.js:137:11
10:29:35     INFO -  3980 INFO TabTarget.prototype.destroy@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/target.js:447:5
10:29:35     INFO -  3981 INFO TabTarget.prototype.handleEvent@resource://gre/modules/commonjs/toolkit/loader.js -> resource:///modules/devtools/framework/target.js:408:9
10:29:35     INFO -  3982 INFO _beginRemoveTab@chrome://browser/content/tabbrowser.xml:2008:13
10:29:35     INFO -  3983 INFO removeTab@chrome://browser/content/tabbrowser.xml:1894:18
10:29:35     INFO -  3984 INFO removeCurrentTab@chrome://browser/content/tabbrowser.xml:1865:13
10:29:35     INFO -  3985 INFO cleanup@chrome://mochitests/content/browser/browser/devtools/styleeditor/test/head.js:60:5
Assignee

Comment 8

5 years ago
Looks like the destroy gets called before domReady sets this.webconsolePanel.  Just checks in the destroy function before doing anything to it.  Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=f887d5c44feb
Attachment #8479338 - Flags: review?(fayearthur)
Attachment #8479338 - Flags: review?(fayearthur) → review+
Assignee

Updated

5 years ago
Keywords: checkin-needed
Assignee: nobody → bgrinstead
Assignee

Comment 11

5 years ago
Found a test to skip that I missed the first time around (failures can be seen here: https://tbpl.mozilla.org/php/getParsedLog.php?id=46912519&tree=Holly&full=1).

Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=e4e26534c243
Attachment #8480610 - Flags: review?(fayearthur)
Attachment #8480610 - Flags: review?(fayearthur) → review+
Assignee

Comment 12

5 years ago
Had an unrelated error in the last try push, here's a new one https://tbpl.mozilla.org/?tree=Try&rev=1f4f0870b956.
Keywords: checkin-needed
Assignee

Updated

5 years ago
Attachment #8474880 - Flags: checkin+
Assignee

Updated

5 years ago
Attachment #8479338 - Flags: checkin+
Assignee

Updated

5 years ago
Attachment #8480610 - Flags: checkin+
Moving DevTools test bugs to e10s milestone M7 (i.e. not blocking e10s merge to Aurora).
Whiteboard: [e10s-m7]
No longer blocks: 1058875
Assignee

Comment 16

4 years ago
Posted patch styleeditor-e10s-pt4.patch (obsolete) — Splinter Review
Skip remaining tests -- this won't work until Bug 1128988 is fixed (since the cmd_edit test is using a gcli command)
Assignee

Updated

4 years ago
Depends on: 1128988
Summary: Enable devtools/styleeditor tests with e10s → [e10s] Enable devtools/styleeditor tests
Assignee

Comment 18

4 years ago
Comment on attachment 8601037 [details] [diff] [review]
styleeditor-e10s-pt4.patch

The e10s dt failure here looks unrelated: https://treeherder.mozilla.org/#/jobs?repo=try&revision=290ff488448a.  Retriggered a few more just to be sure, but looking like we should be able to close this one out.
Attachment #8601037 - Flags: review?(ejpbruel)
Attachment #8601037 - Flags: review?(ejpbruel) → review+
ni? bgrins because I'm wondering if this isn't easy to land?
Flags: needinfo?(bgrinstead)
Assignee

Comment 21

4 years ago
Test failures on browser_styleeditor_sourcemap_watching.js in e10s on that push.  Here's a new one that might fix it: https://treeherder.mozilla.org/#/jobs?repo=try&revision=26b5ba59b44d
Assignee

Comment 22

4 years ago
Try looks good.. Checking into fx-team
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)
Keywords: leave-open

Comment 24

4 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ebabcb64dab6
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46

Comment 25

3 years ago
[bugday-20160323]

Status: RESOLVED,FIXED -> UNVERIFIED

Component: 
Name 			Firefox
Version 		46.0b4
Build ID 		20160322075646
Update Channel 	        beta
User Agent 		Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
OS                      Windows 7 SP1 x86_64

Actual Results: 
Unverified

Expected Results: 
Unable to perform steps due to STR are not mentioned clearly.

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.