Dolphin (v1.4) of Media storage, the first "Format SD card " should change to "Format internal storage"

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: Shufang.Xu, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

4 years ago
[repro Steps    ]:
1.Add some image to internal storage from Camera 
2.Settings->Media storage
3.Click the first "Format SD card",but Device did not do anything.

[Expected Result  ]:
The first "Format SD card" should change to "Format internal storage", and clear internal storage.
(Reporter)

Comment 1

4 years ago
"Format internal storage" function as "Format SD card", you can Format stored inside the cell phone pictures, music, movies.
(Reporter)

Comment 2

4 years ago
Dear Evelyn Hung:
I don't know if the underlying implementation interface of this feature, please check it.
Flags: needinfo?(ehung)
(Reporter)

Comment 3

4 years ago
Dear Fernando Jiménez Moreno:
I don't know if the underlying implementation interface of this feature, please help to check it,Thank you very much!
Flags: needinfo?(ferjmoreno)
(Reporter)

Comment 4

4 years ago
Dear  Michael Henretty:
I don't know if the underlying implementation interface of this feature, please help to check it,Thank you very much!
Flags: needinfo?(mhenretty)
(Reporter)

Comment 5

4 years ago
Dear  William Hsu:
please help me to check it,trouble you again,Thank you very much!
Flags: needinfo?(whsu)

Comment 6

4 years ago
Shufang,

Per your description, here are two issues:
1. the button should be renamed as "format internal storage"
2. the storage should be formatted

For 1, please file another bug, so people won't get confused.

For 2, two things will happen when you click the format button
a) displays a pop up window to alert you this action will remove all data
b) if you confirm the action, Settings app will call |format()| of deviceStorage API.
https://github.com/mozilla-b2g/gaia/blob/v1.4/apps/settings/js/media_storage.js#L262

Could you identify where the issue is caused? (a or b)
Flags: needinfo?(whsu)
Flags: needinfo?(mhenretty)
Flags: needinfo?(ferjmoreno)
Flags: needinfo?(ehung)
(Reporter)

Comment 7

4 years ago
(In reply to Evelyn Hung [:evelyn] from comment #6)
> Shufang,
> 
> Per your description, here are two issues:
> 1. the button should be renamed as "format internal storage"
> 2. the storage should be formatted
> 
> For 1, please file another bug, so people won't get confused.
> 
> For 2, two things will happen when you click the format button
> a) displays a pop up window to alert you this action will remove all data
> b) if you confirm the action, Settings app will call |format()| of
> deviceStorage API.
> https://github.com/mozilla-b2g/gaia/blob/v1.4/apps/settings/js/media_storage.
> js#L262
> 
> Could you identify where the issue is caused? (a or b)

I think it should be (a), should reboot prompt box. But now the two buttons display are "Format SD card" 

My analysis of the reasons are:

  var storages. = the navigator getDeviceStorages(type);
Returned array: 
  storages = [" sdcard ", "sdcard0"] // phone memory, sd card memory
  createView (volumeListRootElement) //this code carry out twice, thus creating two times
"Format SD card" button.
(Reporter)

Comment 8

4 years ago
Dear evehyn:

I think it should be (a), should reboot prompt box. But now the two buttons display are "Format SD card" 

My analysis of the reasons are:

  var storages. = the navigator getDeviceStorages(type);
Returned array: 
  storages = [" sdcard ", "sdcard0"] // phone memory, sd card memory
  volume.createView(volumeListRootElement) //this code carry out twice, thus creating two times
"Format SD card" button.
 
Could I need to make a new bug? Which means I want to say as you describe.Trouble you again,Thanks!
Flags: needinfo?(ehung)

Comment 9

4 years ago
okay, I tested. it's (b). I saw there is a dialog pops up.

(In reply to Shufang.Xu from comment #8)
> Dear evehyn:
> 
> I think it should be (a), should reboot prompt box. But now the two buttons
> display are "Format SD card" 
> 
> My analysis of the reasons are:
> 
>   var storages. = the navigator getDeviceStorages(type);
> Returned array: 
>   storages = [" sdcard ", "sdcard0"] // phone memory, sd card memory
>   volume.createView(volumeListRootElement) //this code carry out twice, thus
> creating two times
> "Format SD card" button.
>  

Here is the issue.  According to this configuration, 'sdcard' is internal storage, and 'sdcard0' is external storage (a real sdcard). If you didn't insert a sdcard, then the second button shouldn't be clicked. Can you check if your hardware configuration is correct?


> Could I need to make a new bug? Which means I want to say as you
> describe.Trouble you again,Thanks!

No, not this one. 
You should file another bug for renaming "Format sdcard" to be "Format Internal Storage".
Flags: needinfo?(ehung)

Comment 10

4 years ago
Thanks Evelyn!
I have helped to submit another bug. Bug 1055578
If I can be of any further help, please let me know.

Have a nice day! :)

Comment 11

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 1.4?

Comment 12

4 years ago
(In reply to William Hsu [:whsu] from comment #11)
> [Blocking Requested - why for this release]:

User will be misled by name.

Comment 13

4 years ago
(In reply to William Hsu [:whsu] from comment #12)
> (In reply to William Hsu [:whsu] from comment #11)
> > [Blocking Requested - why for this release]:
> 
> User will be misled by name.

Sorry. Spoke too quick.

User will be misled by name, and basic functionality cannot work.
So, nominate this bug.
Thanks.

Comment 14

4 years ago
(In reply to William Hsu [:whsu] from comment #13)
> (In reply to William Hsu [:whsu] from comment #12)
> > (In reply to William Hsu [:whsu] from comment #11)
> > > [Blocking Requested - why for this release]:
> > 
> > User will be misled by name.
> 
> Sorry. Spoke too quick.
> 
> User will be misled by name, and basic functionality cannot work.

"User will be misled by name" is the impact of bug 1055578, not this one.

Thank William for filing the bug.
(In reply to Evelyn Hung [:evelyn] from comment #9)

> Here is the issue.  According to this configuration, 'sdcard' is internal
> storage, and 'sdcard0' is external storage (a real sdcard). If you didn't
> insert a sdcard, then the second button shouldn't be clicked. Can you check
> if your hardware configuration is correct?
> 
> 

So this one here isn't a valid bug here?
blocking-b2g: 1.4? → -

Comment 16

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.