immediately change message position when starred status of email changes

RESOLVED DUPLICATE of bug 259781

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED DUPLICATE of bug 259781
4 years ago
2 years ago

People

(Reporter: Yet Ding, Unassigned)

Tracking

32 Branch
x86_64
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8475032 [details]
img002.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140722064054

Steps to reproduce:

1. Sort by "star" "descending" "threaded"
2. Starr a message in inbox


Actual results:

The newly starred message is not automatically resorted according to its starred status. It remains in the default order without respecting the sort criteria. See the attached screenshot


Expected results:

I expect a newly starred message to be automatically re-sorted according to its starred status

Comment 1

4 years ago
I am affected by precisely the same issue. I am also using Gmail.

Can someone confirm whether this is a Gmail specific issue?
(In reply to Yet Ding from comment #0)
> Expected results:
> I expect a newly starred message to be automatically re-sorted according to its starred status

When other field(column) such as Tag, Read/Unread, "automatic sorting agagin by the column" is not executed by Tb currently.
I believe housekeeping work like "changing Starred,Tag,Read/Unread etc." is better done with currently sorted order without changing position of a mail at Thread Pane. If position of a marked mail is changed while doing housekeeping work, I believe it's annoying for many users, because "cancel the marking" is hard and it always changes position of the mail too.

This is also applicable to "Search Folder"(Virtual Folder).
   When search condition is "mail marked as Starred",
   if a mail is removed from the  "Search Folder" immediately by "removing Starred mark",
   "cancel of removing Starred mark" is impossible.

What do you think?

(In reply to orschiro from comment #1)
> I am affected by precisely the same issue. I am also using Gmail.
> Can someone confirm whether this is a Gmail specific issue?

Gmail's [Gmail]/Starred folder?

If [Gmail]/Starred, mail in [Gmail]/Starred is "mail marked as Starred" only.
i.e. If Starred status is removed by Tb(\Flagged flag is removed by Tb), UID of the mail is automatically removed by Gmail.
i.e. "Sorting of mails in [Gmail]/Starred folder by Starred column" is essentially nonsense.
Note:
"expunging of the mail in [Gmail]/Starred by removing Starred status" doesn't look notified to IMAP client from Gmail IMAP.
So, "re-adding of Starred to the UID" is ignored by Gmail/Gmaail IMAP.
Once Starred status is removed from a mail in [Gmail]/Starred, "re-adding of Starred to the mail in [Gmail]/Starred by Tb" won't do anything. So, once Starred status is removed from a mail in [Gmail]/Starred,  the mail wont't be shown in [Gmail]/Starred, until Starred status(\Flagged flag) is added again at other folder such as [Gmail]/All Mail, and until [Gmail]/Starred is re-opened.

Please open separate bug if [Gmail]/Starred folder is involved in your problem.

Comment 3

4 years ago
@WADA

I am not sure if I completely understand your comment. You suggest that the problem described above is intended and immediate update of the sorting does not make even sense?

> Please open separate bug if [Gmail]/Starred folder is involved in your problem.

I don't know about the [Gmail]/Starred folder because my starred emails are to be found right in the folder Inbox.
(In reply to orschiro from comment #3)
> the problem described above is (a) intended and (b) immediate update of the sorting does not make even sense?

(a) : I believe current behaviour is intended.
(b) : I never say "immediate update of the sorting does not make sense".
        "immediate update of the sorting" is reasonable for "ad-hoc Starred marking of only one mail always".
        Example : Windows Explorer changes order of files accordig to file name/file extension change.
        However, for housekeeping work, categorizing of mails, for example, check new mails and mark important mails as Starred
        etc. and check many marked mails, "immediate update of the sorting" is not so appropriate for many users.
        "file name/file extension change in Windows Explorer" correspnds to "Subject change" like one in mailer.

About [Gmail]/Starred folder which is presented to IMAP client by Gmail IMAP.
   Mail folder named "Starred" at Gmail's Web Interface.
   This Gmail's folder is presented as [Gmail]/Starred folder to IMAP client by Gmail IMAP.
   "Marking as Starred at Gmail" is identical to "uid xx store +Flags(\Flagged)" in IMAP(and Gmail IMAP too).
As for "immediate update of the sorting by Thread Pane column of a mail folder in Thunderbird", there is no particularity of Gmail/Gmail IMAP.

Comment 5

4 years ago
@WADA

I am not sure if I completely understood your reply. 

How should we proceed from here?

If I understood you right, it is the intended behaviour that Thunderbird does not re-order my emails after marking a single email "starred" until I switch folders, thus refreshing the list. 

Correct?

Comment 6

3 years ago
I would like to make a follow-up on this since this issue is very annoying to me and I would really like to know whether the issue is on the side of TB, Gmail or my system. 

Just to recall my precise problem, I made the following screencast:

https://mediacru.sh/BMFAYQ2kLBx3

Please have a look at it and tell me if you can reproduce the error. 

Thank you!
(In reply to orschiro from comment #5)
> @WADA
> If I understood you right, it is the intended behaviour that 
> Thunderbird does not re-order my emails after marking a single email "starred" until I switch folders, thus refreshing the list. 
> Correct?

Yes.

(In reply to orschiro from comment #6)
> and I would really like to know whether the issue is on the side of TB, Gmail or my system. 
> Just to recall my precise problem, I made the following screencast:
> https://mediacru.sh/BMFAYQ2kLBx3

What is purpose of this screen shot?
For phenomenon that "Mail in Gmail IMAP marked as Starred by other IMAP client including different instance of Tb" is not automatically marked as Starred at your Thunderbird? (phenomenon of bug 693204, bug 512745?)

If Starred mark is added by this Tb, there is no Gmail related issue in this bug. "Gmail or not Gmail" should be irrelevant.
If Starred mark is added by this Tb, to which mail was Starred added? 
Screen shot looks for me "sorted again by Starred column always as you expect"...

Comment 8

3 years ago
> What is purpose of this screen shot?
The purpose was to better describe my question.

> If Starred mark is added by this Tb, there is no Gmail related issue in this bug. "Gmail or not Gmail" > should be irrelevant.
> If Starred mark is added by this Tb, to which mail was Starred added? 
> Screen shot looks for me "sorted again by Starred column always as you expect"...

Indeed, it is not a Gmail issue. Now, knowing that it no automatic refresh after starring an email is intended, I will look into how this functionality could be provided by an add-on.
Severity: normal → enhancement

Comment 9

2 years ago
It took me quite some time to find that this is what bug 259781 talks about, i.e. working as designed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → Folder and Message Lists
OS: Linux → All
Resolution: --- → DUPLICATE
Summary: Automatic sorting of starred emails not working → immediately change message position when starred status of email changes
Duplicate of bug: 259781
You need to log in before you can comment on or make changes to this bug.