Machine being used for tests added to prod pool before being cleaned up

RESOLVED FIXED

Status

Release Engineering
Buildduty
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: massimo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
We hit this error on linux repacks for 32.0b8 build1 

INFO: mock_mozilla.py version 1.0.3 starting...
State Changed: init plugins
INFO: selinux disabled
State Changed: start
Mock Version: 1.0.3
INFO: Mock Version: 1.0.3
State Changed: lock buildroot
INFO: installing package(s): autoconf213 python zip mozilla-python27-mercurial git ccache glibc-static.i686 libstdc++-static.i686 perl-Test-Simple perl-Config-General gtk2-devel.i686 libnotify-devel.i686 yasm alsa-lib-devel.i686 libcurl-devel.i686 wireless-tools-devel.i686 libX11-devel.i686 libXt-devel.i686 mesa-libGL-devel.i686 gnome-vfs2-devel.i686 GConf2-devel.i686 wget mpfr xorg-x11-font* imake gcc45_0moz3 gcc454_0moz1 gcc472_0moz1 gcc473_0moz1 yasm ccache valgrind pulseaudio-libs-devel.i686 gstreamer-devel.i686 gstreamer-plugins-base-devel.i686 glibc-devel.i686 libgcc.i686 libstdc++-devel.i686 ORBit2-devel.i686 atk-devel.i686 cairo-devel.i686 check-devel.i686 dbus-devel.i686 dbus-glib-devel.i686 fontconfig-devel.i686 glib2-devel.i686 hal-devel.i686 libICE-devel.i686 libIDL-devel.i686 libSM-devel.i686 libXau-devel.i686 libXcomposite-devel.i686 libXcursor-devel.i686 libXdamage-devel.i686 libXdmcp-devel.i686 libXext-devel.i686 libXfixes-devel.i686 libXft-devel.i686 libXi-devel.i686 libXinerama-devel.i686 libXrandr-devel.i686 libXrender-devel.i686 libXxf86vm-devel.i686 libdrm-devel.i686 libidn-devel.i686 libpng-devel.i686 libxcb-devel.i686 libxml2-devel.i686 pango-devel.i686 perl-devel.i686 pixman-devel.i686 zlib-devel.i686 freetype-2.3.11-6.el6_1.8.i686 freetype-devel-2.3.11-6.el6_1.8.i686 freetype-2.3.11-6.el6_1.8.x86_64
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/builds/mock_mozilla/mozilla-centos6-x86_64/root/', 'install', 'autoconf213', 'python', 'zip', 'mozilla-python27-mercurial', 'git', 'ccache', 'glibc-static.i686', 'libstdc++-static.i686', 'perl-Test-Simple', 'perl-Config-General', 'gtk2-devel.i686', 'libnotify-devel.i686', 'yasm', 'alsa-lib-devel.i686', 'libcurl-devel.i686', 'wireless-tools-devel.i686', 'libX11-devel.i686', 'libXt-devel.i686', 'mesa-libGL-devel.i686', 'gnome-vfs2-devel.i686', 'GConf2-devel.i686', 'wget', 'mpfr', 'xorg-x11-font*', 'imake', 'gcc45_0moz3', 'gcc454_0moz1', 'gcc472_0moz1', 'gcc473_0moz1', 'yasm', 'ccache', 'valgrind', 'pulseaudio-libs-devel.i686', 'gstreamer-devel.i686', 'gstreamer-plugins-base-devel.i686', 'glibc-devel.i686', 'libgcc.i686', 'libstdc++-devel.i686', 'ORBit2-devel.i686', 'atk-devel.i686', 'cairo-devel.i686', 'check-devel.i686', 'dbus-devel.i686', 'dbus-glib-devel.i686', 'fontconfig-devel.i686', 'glib2-devel.i686', 'hal-devel.i686', 'libICE-devel.i686', 'libIDL-devel.i686', 'libSM-devel.i686', 'libXau-devel.i686', 'libXcomposite-devel.i686', 'libXcursor-devel.i686', 'libXdamage-devel.i686', 'libXdmcp-devel.i686', 'libXext-devel.i686', 'libXfixes-devel.i686', 'libXft-devel.i686', 'libXi-devel.i686', 'libXinerama-devel.i686', 'libXrandr-devel.i686', 'libXrender-devel.i686', 'libXxf86vm-devel.i686', 'libdrm-devel.i686', 'libidn-devel.i686', 'libpng-devel.i686', 'libxcb-devel.i686', 'libxml2-devel.i686', 'pango-devel.i686', 'perl-devel.i686', 'pixman-devel.i686', 'zlib-devel.i686', 'freetype-2.3.11-6.el6_1.8.i686', 'freetype-devel-2.3.11-6.el6_1.8.i686', 'freetype-2.3.11-6.el6_1.8.x86_64']
Package python-2.6.6-29.el6.x86_64 already installed and latest version
Package mpfr-2.4.1-6.el6.x86_64 already installed and latest version
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Package libjpeg is obsoleted by libjpeg-turbo, but obsoleting package does not provide for requirements
Error: Package: libtiff-3.9.4-1.el6_0.3.i686 (centos6)
           Requires: libjpeg.so.62
           Available: libjpeg-6b-46.el6.i686 (centos6)
               libjpeg.so.62
 You could try using --skip-broken to work around the problem
Error: Package: gtk2-2.18.9-6.el6.centos.i686 (centos6)
           Requires: libjpeg.so.62
           Available: libjpeg-6b-46.el6.i686 (centos6)
               libjpeg.so.62
Error: Package: jasper-libs-1.900.1-15.el6_1.1.i686 (centos6-updates)
           Requires: libjpeg.so.62
           Available: libjpeg-6b-46.el6.i686 (centos6)
               libjpeg.so.62
Error: Package: 1:cups-libs-1.4.2-44.el6.i686 (centos6)
           Requires: libjpeg.so.62
           Available: libjpeg-6b-46.el6.i686 (centos6)
               libjpeg.so.62
 You could try running: rpm -Va --nofiles --nodigest

After some troubleshooting with simone, we realizd this happened because the b-linux64-hp-0025 box has been added to the prod pool before being cleaned up (it had been used by simone to run some tests and it was pinned to his puppet environment)
See https://bugzilla.mozilla.org/show_bug.cgi?id=825637

Updated

3 years ago
Component: Platform Support → Buildduty
QA Contact: coop → bugspam.Callek
Ah, that explains the error on release-mozilla-beta-firefox_source too.
Assuming it's fixed now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.