Closed Bug 1055531 Opened 5 years ago Closed 17 days ago

Pin/Close buttons always visible on about:newtab on Windows 8

Categories

(Firefox :: New Tab Page, defect)

33 Branch
x86
Windows 8
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: phlsa, Unassigned)

References

Details

(Keywords: regression)

In the last few Nightlies, the pin and close buttons on tiles are always visible. They should only appear on hover.

This only happens on Windows 8, not on Windows 7. I tested it with a clean profile.
emtwo did some digging around and found that touch devices always have opacity set to 1:

http://hg.mozilla.org/mozilla-central/annotate/4d94eeca89f3/browser/base/content/newtab/newTab.css#l182

Implemented by bug 735564.
Depends on: 735564
Summary: Pin/Close buttons always visible on about:newtab on Windows → Pin/Close buttons always visible on about:newtab on Windows 8
(In reply to Philipp Sackl [:phlsa] from comment #0)
> In the last few Nightlies
Did this only start happening recently? Perhaps something changed in what triggers "-moz-touch-enabled"
(In reply to Ed Lee :Mardak from comment #2)
> (In reply to Philipp Sackl [:phlsa] from comment #0)
> > In the last few Nightlies
> Did this only start happening recently? Perhaps something changed in what
> triggers "-moz-touch-enabled"

I didn't use my Windows VM for some time, but it already showed up a couple of days ago. So it isn't super-new.
Component: General → New Tab Page
This doesn't reproduce on Win10 (tested the 2014-08-09 nightly as well). Do you still see this, Philipp?
Flags: needinfo?(philipp)
Hm, It's still the case on my XPS 13. As noted in comment 1, it seems that touch devices always show the icons (which makes some sense, because otherwise you wouldn't be able to use those icons on a pure touch device). Still just showing them all the time on all tiles is a pretty crude solution, but solving this is more of a design issue rather than an engineering issue.
Flags: needinfo?(philipp)
Doesn't sound like tracking down a regression range is going to help much, in that case.
There should be a mobile-specific solution. Such as tap-and-hold to launch a menu...

Hello!

This bug has been closed due to inactivity and/or the potential for this bug to no longer be an issue with the new Discovery Stream-powered New Tab experience.

Please help us triage by reopening if this issue still persists and should be addressed.

Thanks!

Status: NEW → RESOLVED
Closed: 17 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.