Closed Bug 10556 Opened 20 years ago Closed 20 years ago

Borders in boxes drawn incorrectly.

Categories

(Core :: XUL, defect, P3)

x86
Other
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: hyatt, Assigned: eric)

Details

Take a look at this:

<?xml version="1.0"?>
<?xml-stylesheet href="xul.css" type="text/css"?>

<!DOCTYPE window>

<window style="width: 100%; height: 100%"
xmlns:html="http://www.w3.org/TR/REC-html40"
        xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
<box style="width:400px; border: thin solid black">
<titledbutton style="width: 200px" value="Child 1"/>
<titledbutton style="width: 100px" value="Child 2"/>
</box>
</window>

In the above example, the thin black border should be drawn around the box,
and it should be 400 pixels wide.  The box itself is obviously the right
size (400px), but it is only drawing the border around its content (which
is only 300px wide).
Status: NEW → ASSIGNED
Target Milestone: M10
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
QA Contact: ckritzer → hyatt
Assigning to originator per new organizational structure.
QA Contact: hyatt → ckritzer
Changing QA Contact back to ckritzer@netscape.com
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL
Massive QA Contact update.
QA Contact: ckritzer → jrgm
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.