Hidden Canvas disappearing when a new page is loading

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
4 years ago
a year ago

People

(Reporter: Krassmus, Unassigned)

Tracking

({reproducible, testcase})

31 Branch
reproducible, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715214327

Steps to reproduce:

I have a site (i.e http://develop.studip.de/studip/index.php the top-icons "start" and "freie") that is containing multiple canvas. In fact it has two canvasses per item - one for hover-effect and one for non-hover. I am drawing both shortly after the page has loaded and I am switching between them with CSS :hover.


Actual results:

At first everything is fine. But when I click on an item and the browser is starting to load the new page, but the old page is still there, the switching between hovered canvas and non-hovered canvas doesn't work anymore. The CSS-selector still works, but the formally hidden canvas doesn't show. The icon simply disappears.


Expected results:

The page should still behave as it did before I clicked the icon until of course the new page is actually appearing on my screen. But this might take a while and it is confusing to see icons disappear in the meantime.

Comment 1

4 years ago
Created attachment 8476632 [details]
home.png

Comment 2

4 years ago
Created attachment 8476633 [details]
seminar.png

Comment 3

4 years ago
Created attachment 8476635 [details]
Testcase

Comment 4

4 years ago
I can reproduce with the attached testcase. Note that if you use the back button afterwards, bfcache shows you empty space until you hover over the canvas, too. I'm not really sure what's going on (and if it's just a layer invalidation issue or if the canvas is actually hidden, or just not painted, or ...), so I'm just going to move this to Core::Untriaged and hope someone else can dive in further.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible, testcase
OS: Linux → All
Hardware: x86_64 → All

Updated

4 years ago
Component: Untriaged → Untriaged
Product: Firefox → Core

Comment 5

3 years ago
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID 	20160105030211

I tried to reproduce this, but it worked fine for me on Nightly 46. Could you check if the issue is still reproducing on your side on latest Firefox versions (Firefox 43 or Nightly 46)?
Flags: needinfo?(Krassmus)

Comment 6

3 years ago
Closing this as incomplete due to lack of response from the reporter. Feel free to reopen the bug if the issue still reproduces on a current build.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(Krassmus)
Resolution: --- → INCOMPLETE
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.