[Contacts] when selecting year for birthday, if year is scrolled to fast box will close

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: RJ, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.1-flame-test-run-1], URL)

Attachments

(1 attachment)

16.85 KB, application/vnd.oasis.opendocument.text
Details
(Reporter)

Description

4 years ago
Created attachment 8475305 [details]
birthdaylogcat.odt

Repro Steps:
1) Update a Flame to 20140818040201
2) Open contacts app< Have a contact< edit contact 
3) Scroll down to birthday< tap on the birthday drop down
4) Scroll down on the year with fast long swipes


Actual:
Dialog box closes with nothing saved 


Expected:
Dialog box does not close 

Environmental Variables:
Device: Flame Master
Build ID: 20140818040201
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: 0aaa2d3d15cc
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Keywords: Contacts, Date, Year scroll


Notes: This also occures when notification try is toggled 


Repro frequency:2/3
See attached: video clip
(Reporter)

Comment 1

4 years ago
This issue DOES reproduce on Flame 2.1 (319mb),Buri 2.1, Flame 2.0 (512mb) Flame 2.0(319mb),Buri 2.0, Flame 1.4, And Buri 1.4

"Flame 2.1

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140818040201
Gaia: aa8aace12d65956dd9525da5dac66e0d3b28597f
Gecko: 0aaa2d3d15cc
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0"

"Buri 2.1

Environmental Variables:
Device: Buri 2.1 Master
BuildID: 20140818073016
Gaia: ba1992f2addc5a84afc2eab426f222a6bf2962ba
Gecko: bf27e27c994d
Version: 34.0a1 (2.1 Master)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
"

"Flame 2.0


Environmental Variables:
Device: Flame 2.0 (319mb)
BuildID: 20140818000201
Gaia: fb2dd31abed2803eb7ad67eb4c52abb48de1e0f7
Gecko: 09f7a7184c71
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
"

"Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140818063008
Gaia: 640ce38ca03f1e26a4524ff4215b8b3f7731e2f0
Gecko: 692c93509dc9
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
"

"Flame 1.4

Environmental Variables:
Device: Flame 1.4 (319mb)
Build ID: 20140818063007
Gaia: 21bec64497dc06a7f12071d573570ba8fea598ae
Gecko: 07d78d0f9bef
Version: 30.0 (1.4)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
"

"Buri 1.4

Environmental Variables:
Device: Buri 1.4
BuildID: 20140818063007
Gaia: 21bec64497dc06a7f12071d573570ba8fea598ae
Gecko: 07d78d0f9bef
Version: 30.0 (1.4)
Firmware: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0"
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.1-exploratory]
(Reporter)

Updated

4 years ago
Whiteboard: [2.1-exploratory] → [2.1-flame-test-run-1]
Please stop putting quotes in your environmental variables. Also, please update the correct tracking flags. 

Also, remove [B2G] from your title and do not put keywords in your bugs.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker)
QA Wanted to check if this issue also occurs on the E-Mail app: Go to add a new event and try to change the year of this event. Make this check only on 2.1 on the Flame. No need to verify all the branches/devices.
Keywords: qawanted
needinfo for comment 2
Flags: needinfo?(rmitchell)
(Reporter)

Updated

4 years ago
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(rmitchell)
Summary: [B2G][Contacts][Edit contact] when selecting year for birthday, if year is scrolled to fast box will close → [Contacts][Edit contact] when selecting year for birthday, if year is scrolled to fast box will close
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Summary: [Contacts][Edit contact] when selecting year for birthday, if year is scrolled to fast box will close → [Contacts] when selecting year for birthday, if year is scrolled to fast box will close
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
(In reply to Johan Lorenzo [:jlorenzo] from comment #3)
> QA Wanted to check if this issue also occurs on the E-Mail app: Go to add a
> new event and try to change the year of this event. Make this check only on
> 2.1 on the Flame. No need to verify all the branches/devices.

Hi Johan,
   I read your comment and you mention the Email app and adding a new event? Did you mean Calendar app? I went to the Calendar app and was able to reproduce this issue with date pickers.

The issue is not with long swipes. If the user taps the notification bar at the top, the window for date pickers will just close out. From the video it seem the bar at the top was touched which will close out the birthday window.

Environmental Variables:
Device: Flame Master
BuildID: 20140825085054
Gaia: a25ae14dbd2fe3e25144a7064efc0cc4e31042b8
Gecko: 4ca2bd0722d9
Version: 34.0a1 (Master) 
Firmware Version: v123
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 6

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.