smartfilterwhere.com - <a />foo</a> link slash href html

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P4
normal
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Dan Mellem, Assigned: bc)

Tracking

Details

(Whiteboard: [EMPTY-TAG], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

When a link has the format
   <A HREF="/index.html"/> linktext </a>

The "linktext" is not a link. However,
   <A HREF="/index.html"> linktext </a>

works fine.The first example works fine in Communicator 4.77.

Reproducible: Always
Steps to Reproduce:
Go to URL above or create a simple HTML document with:
<HTML>
<a href=".."/>This is a link.</a>
</HTML>
Keywords: 4xp
Summary: 4xp: A HREF= link with trailing slash / (before >) results in missing link → [quirks]A HREF= link with trailing slash / (before >) results in missing link
This would require a large rearchitecting of the parser.  Since <a href="foo" />
means <a href="foo"></a> we are parsing this correctly for XML documents and
XHTML.  In HTML this is an invalid construct that people seem to feel it is cool
to use.

Over to evangelism; Harish has explicitly said on multiple occasions that he
will not be changing this behavior.
Assignee: harishd → bclary
Status: UNCONFIRMED → NEW
Component: Parser → English: US
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: moied → zach
Hardware: PC → All
Version: other → unspecified
(Assignee)

Updated

16 years ago
Keywords: 4xp
Priority: -- → P4
Summary: [quirks]A HREF= link with trailing slash / (before >) results in missing link → smartfilterwhere.com - <a />foo</a>
Whiteboard: [EMPTY-TAG]
(Reporter)

Comment 2

16 years ago
I'm adding some words on the summary line so this is easier to find (to reduce
dups).
Summary: smartfilterwhere.com - <a />foo</a> → smartfilterwhere.com - <a />foo</a> link slash href html
(Assignee)

Comment 3

16 years ago
looks fixed to me.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

16 years ago
You're right. I just checked it a week or two ago and it wasn't fixed so I sent
another e-mail to webmaster. -Dan

Comment 5

16 years ago
Verified
2002022703/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.