Paid apps are getting listed as "Unavailable" on feed

RESOLVED DUPLICATE of bug 1055962

Status

--
blocker
RESOLVED DUPLICATE of bug 1055962
4 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Assigned: kngo)

Tracking

x86
All
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8475374 [details]
screenshot

steps to reproduce:
1. Launch feeddev packaged app on your firefoxos device with region set to RoW
2. In the feed, find the paid app "Test Zippy With Me"

expected behavior:
User can start the purchase flow as the button is enabled 

actual behavior:
Install button for the paid app is listed as "Unavailable"
(Assignee)

Comment 1

4 years ago
This is because Fireplace is model caching apps from collection tiles when we don't want it to. Find out where it's model caching apps and tell it to stahp.
(Assignee)

Updated

4 years ago
Assignee: nobody → kngo
(Assignee)

Comment 2

4 years ago
How come the apps changed to Free?
(Assignee)

Comment 3

4 years ago
Never mind, it's because RoW doesn't support payments. The actual bug is that we should filter out region exclusions.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1055962
You need to log in before you can comment on or make changes to this bug.