We don't redraw the focus ring properly in e10s mode when going back to a page where you opened a link from

NEW
Unassigned

Status

()

P2
normal
4 years ago
16 days ago

People

(Reporter: Ehsan, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

4 years ago
I'm not sure if layout is the right component for this...

STR:
1. Go to a bugzilla query page, such as https://bugzilla.mozilla.org/page.cgi?id=mydashboard.html.
2. Open a bug in a new tab by clicking on a link while holding down Cmd.
3. Use the keyboard to go back to the original tab (for example by by Cmd+Alt+Left).

In non-e10s, we draw the focus ring around the clicked link.  In e10s, we don't draw it.

Updated

4 years ago
Assignee: nobody → davidp99
tracking-e10s: ? → +

Comment 1

4 years ago
Yes, the code that does this is disabled:

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/tabbrowser.xml#1254
Keywords: qawanted

Updated

3 years ago
Assignee: davidp99 → nobody
Priority: -- → P2
I managed to reproduce this issue on the latest Aurora build(46.0a2) on Mac OS 10.11. Using steps 1 to 3, with e10s disabled, the link in the previous page has a ring around it, but when e10s is enabled, the ring is not drawn around the link.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160204004009
tracking-e10s: + → ?

Comment 3

3 years ago
Jeff, do you think we should block on this or put it in our high priority tracking plus bugs?
Flags: needinfo?(jgriffiths)

Comment 4

3 years ago
Oh, sorry, I see we already did that. nm.
tracking-e10s: ? → +
Flags: needinfo?(jgriffiths)
Keywords: qawanted

Updated

2 years ago
Duplicate of this bug: 1301631

Updated

2 years ago
OS: Mac OS X → All

Updated

2 years ago
Hardware: x86 → All
The duplicate bug has this nominated for branches started at 49 - if someone could clarify which branches are affected that would be immensely helpful.

Comment 7

2 years ago
This has never worked on e10s, so all branches are affected.

Comment 8

2 years ago
It worked well in Firefox 49, but no longer in 50.

Comment 9

2 years ago
Still not working in Firefox 51.0.1 64 bits in Windows.

Updated

5 months ago
Duplicate of this bug: 1460308
You need to log in before you can comment on or make changes to this bug.