Closed Bug 1055753 Opened 7 years ago Closed 7 years ago

The input autocomplete looks "funny" in e10s

Categories

(Toolkit :: Autocomplete, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla35
Tracking Status
e10s + ---

People

(Reporter: ehsan.akhgari, Assigned: enndeakin)

References

Details

Attachments

(2 files)

Attached image Screenshot
See the screenshot, specifically the gray copies of each entry towards the right side of the popup.  This looks kind of intentional, but it makes no sense!
BTW, the STR is: file a bug. ;-)
Assignee: nobody → felipc
Blocks: old-e10s-m2
Priority: -- → P2
Fixed on today's nightly.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
It's back now.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Do you have any OS accessibility features turned on? Or are you using RTL?

I can't reproduce it (nor bug 1056391), but I can't help but think they are related.
(In reply to :Felipe Gomes from comment #4)
> Do you have any OS accessibility features turned on?

Sorry, I don't know which accessibility feature you mean.  If you mean the thing that let's you focus things such as text boxes in XUL/native dialogs, yes, I do.

> Or are you using RTL?

No.

> I can't reproduce it (nor bug 1056391), but I can't help but think they are
> related.

They are related because they were both fixed, and unfixed.  I also demoed it to Neil Deakin and he couldn't repro either.  Are you on 10.9?  I'm on 10.9.4.
Ok, I managed to reproduce it. Proper steps are:

- Open e10s window
- Use the searchbox in the location bar, which will set showCommentColumn=true in the PopupAutoComplete element, which is used both for the searchbox and content's autocomplete
- Now the autocomplete from content will be displaying the comment column too, with the same text as the row value

So the showCommentColumn property is not being properly set/reset. These same STRs also trigger bug 1056391, but I haven't investigated why yet.
I think this is caused by 947503. I'll investigate that bug.
OK, so forget that last comment. The issue here is that some fields need to be reset before opening the popup. This patch needs to be applied on top of 1017914.

It fixes this bug as well as bug 1056391. Bug 947503 is actually fixed by 1017914 so I removed the extra code for the workaround.
Assignee: felipc → enndeakin
Status: REOPENED → ASSIGNED
Attachment #8481470 - Flags: review?(felipc)
Blocks: 1056391
Depends on: 1017914
Attachment #8481470 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/2ebd93f3e70f
Status: ASSIGNED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.