Add link to privacy policy documentation to submission flow

RESOLVED FIXED

Status

Marketplace
Developer Pages
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: adora, Assigned: jkerim)

Tracking

Avenir
x86
Mac OS X
Points:
---

Details

(Whiteboard: [repoman][contribute])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8475440 [details]
Screenshot of privacy policy field during submission

Many developers misunderstand what we're asking for in this field.  Fortunately, there's documentation on MDN!

Suggested change to help text:  A privacy policy explains what data is transmitted from a user's device, what that data will be used for, and how it is shared.  You can enter your existing privacy policy link or text, or if you don't have a privacy policy, more information on how to write one is available on MDN:  https://developer.mozilla.org/en-US/Marketplace/Publishing/Policies_and_Guidelines/Privacy_policies

Updated

3 years ago
Priority: -- → P3
Whiteboard: [repoman][contribute]
(Assignee)

Updated

3 years ago
Assignee: nobody → jkerim

Comment 1

3 years ago
Thanks Lisa! Here's a suggested tweak to the text.  Feel free to improve upon this :)

"A privacy policy explains how you handle data received through your app.  For example: what data do you receive? How do you use it? Who do you share it with? Do you receive personal information? Do you take steps to make it anonymous? What choices do users have to control what data you and others receive?

Enter your privacy policy link or text above.  If you don't have a privacy policy, learn more on how to write one at:  https://developer.mozilla.org/en-US/Marketplace/Publishing/Policies_and_Guidelines/Privacy_policies"

Comment 2

3 years ago
As the field is mandatory, probably also want an indication of what to do if the app doesn't user/collect personal data, e.g.

If your app doesn't make use of personal data in any way, please enter "This application doesn't collect, use, store, and share or disclose any information about the user or any other person."
(Assignee)

Comment 3

3 years ago
Merged in https://github.com/mozilla/zamboni/pull/2588
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 887370
You need to log in before you can comment on or make changes to this bug.