Closed Bug 1055857 Opened 8 years ago Closed 8 years ago

Change default skin on wiki.mozilla.org to Vector

Categories

(Infrastructure & Operations :: IT-Managed Tools, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: GPHemsley, Assigned: cliang)

References

()

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1082] )

We should begin the transition away from the GMO skin by changing the default skin on MozillaWiki.

To implement this change, $wgDefaultSkin in LocalSettings.php must be set as follows:

>>>
$wgDefaultSkin = 'vector';
<<<

Note that this change only affects anonymous (logged out) users and possibly any users who have an empty skin preference. It does not change any existing users' preferences.

Note also that this change does not remove GMO as an option for a user's skin preference. That will be done in a followup bug.
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1082]
Depends on: 1053113
Blocks: 1055895
(In reply to Gordon P. Hemsley [:GPHemsley] from comment #0)
> Note that this change only affects anonymous (logged out) users and possibly
> any users who have an empty skin preference. It does not change any existing
> users' preferences.

To clarify: It does affect the user preferences of any new users registered after the change has been made.
Assignee: server-ops-webops → cliang
This change was already pushed out to the dev environment, where it is confirmed as working.
In stage, it looks like things are out of date enough that the styling doesn't seem to be working. 
Based on dev working, I pushed this change out to production. 

I've filed a separate bug to get stage working so it will be useful as a testbed again.  (Bug 1056397)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.