Closed Bug 1055909 Opened 5 years ago Closed 5 years ago

Cannot build without google play services - with MOZ_NATIVE_DEVICES unset by branding

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

All
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla35

People

(Reporter: toonetown, Assigned: toonetown)

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.78.2 (KHTML, like Gecko) Version/7.0.6 Safari/537.78.2

Steps to reproduce:

Build with customized branding - which uses a configure.sh script that unsets MOZ_NATIVE_DEVICES.  The configure step of build fails because google play service is required (but it should not be required if MOZ_NATIVE_DEVICES is unset).  This happens because the check for google play service happens before configure.sh is loaded.


Actual results:

build fails during configuration


Expected results:

The check for google play service should happen after the configure.sh script is loaded for a brand.  Attached is a patch which addresses the issue.
Component: General → Build Config & IDE Support
Attachment #8475647 - Attachment is patch: true
Attachment #8475647 - Attachment mime type: text/x-patch → text/plain
Attachment #8475647 - Flags: review?(wjohnston)
Attachment #8475647 - Flags: review?(nalexander)
Summary: Cannot build without google play services - even with MOZ_NATIVE_DEVICES unset → Cannot build without google play services - with MOZ_NATIVE_DEVICES unset by branding
Hi Nathan, thanks for the report and the patch.  I do not feel qualified to review this, so I'm going to request feedback from a different build peer.  However, it does occur that perhaps we should be adding a configure flag like --with{out}-google-play-services or something rather than re-ordering this logic [1].  (As an aside, it's odd that you're setting this as part of branding; I expect it to be part of mozconfig.)

I think glandium is the right person to comment on whether this change is sensible, or whether we should be taking a different approach.  glandium?

[1] wesj started on something like this, but it got backed out: Bug 1033560.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mh+mozilla)
OS: Mac OS X → Android
Hardware: x86 → All
Attachment #8475647 - Flags: review?(wjohnston)
Attachment #8475647 - Flags: review?(nalexander)
Attachment #8475647 - Flags: review?(mh+mozilla)
Yeah - the reason I put you (and west) to review was because you reviewed the lines that I was modifying.  The current android.m4 file uses checks if MOZ_NATIVE_DEVICES is set or not.  This is set in mobile/android/confvars.sh, so it's not able to be reset in a mozconfig (I agree, it would make the most sense to modify it there, probably).  I was resetting the variable value in branding because that was the only way I could find to be able to configure that value, since it was set in confvars.sh.

I am completely fine with a different approach - this was just my first shot at a solution (which did work for me, at least).  Any guidance is appreciated.
Attachment #8475647 - Flags: review?(mh+mozilla) → review+
Updating with hg-formatted patch.  Carrying over review+ from glandium on original patch
Attachment #8475647 - Attachment is obsolete: true
Attachment #8484202 - Flags: review+
Fixing email address used in patch
Attachment #8484202 - Attachment is obsolete: true
Attachment #8484204 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/f00f95bb8900
Assignee: nobody → nathan
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Flags: needinfo?(mh+mozilla)
https://hg.mozilla.org/mozilla-central/rev/f00f95bb8900
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 35
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 35 → mozilla35
You need to log in before you can comment on or make changes to this bug.