Mozmill tests don't run due to no mozinfo

RESOLVED FIXED in Thunderbird 34.0

Status

--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jcranmer, Assigned: jcranmer)

Tracking

({regression})

unspecified
Thunderbird 34.0
regression

Thunderbird Tracking Flags

(thunderbird34 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
I have a simple solution to this, which is to import mozinfo and mozfile (a mozmill dependency) directly into the virtualenv from a mozbase location. This requires a buildbot config change, though. :-(
(Assignee)

Updated

4 years ago
See Also: → bug 1054308
(Assignee)

Comment 1

4 years ago
Created attachment 8475679 [details] [diff] [review]
Install from mozbase.

The obvious person to review this patch would be the person who's away for another 6 days. I'm going to ask Callek to review this patch if he feels comfortable doing so, but I totally understand him not being comfortable.

Another issue that is beyond my personal ability is that this changes the call to installmozmill, which at present requires a buildbot change as well:
<http://mxr.mozilla.org/build/source/buildbotcustom/process/factory.py#4975>. If this is going to involve a complicated buildbot change, it may be worth just spending the effort on bug 1054308 instead.
Assignee: nobody → Pidgeot18
Status: NEW → ASSIGNED
Attachment #8475679 - Flags: review?(standard8)
Attachment #8475679 - Flags: review?(bugspam.Callek)

Updated

4 years ago
Attachment #8475679 - Flags: feedback+
(Assignee)

Comment 2

4 years ago
FWIW, the command line this would need would appear to be
python resources/installmozbuild.py MOZMILL_VIRTUALENV_DIR ../mozbase [since CWD is $TEST_UNPACK_DIR/mozmill, and mozbase is in $TEST_UNPACK_DIR/mozbase]
(Assignee)

Comment 3

4 years ago
Created attachment 8475683 [details] [diff] [review]
Install from mozbase

Note to self: hg qref *before* uploading.
Attachment #8475679 - Attachment is obsolete: true
Attachment #8475679 - Flags: review?(standard8)
Attachment #8475679 - Flags: review?(bugspam.Callek)
Attachment #8475683 - Flags: review?(standard8)
Attachment #8475683 - Flags: review?(bugspam.Callek)
Keywords: regression
OS: Windows 7 → All
Hardware: x86_64 → All
Comment on attachment 8475683 [details] [diff] [review]
Install from mozbase

Review of attachment 8475683 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. I'm happy to put a patch up for the buildbot changes, I'll try and get to it in the next day or two, depending on when I get time to try a full run locally.
Attachment #8475683 - Flags: review?(standard8)
Attachment #8475683 - Flags: review?(bugspam.Callek)
Attachment #8475683 - Flags: review+
(Assignee)

Comment 5

4 years ago
I've pushed the changeset to comm-central:
https://hg.mozilla.org/comm-central/rev/db0269c8f5d3

Keeping this bug open until the buildbot changes happen as well.
Target Milestone: --- → Thunderbird 34.0
Buildbot changes have happened, this is fixed now.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-thunderbird34: --- → fixed
You need to log in before you can comment on or make changes to this bug.