Closed Bug 105597 Opened 21 years ago Closed 9 years ago

Allow customisation of 'additional comments'

Categories

(Bugzilla :: Creating/Changing Bugs, enhancement)

2.15
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 793963

People

(Reporter: martin.ellison, Unassigned)

References

Details

Attachments

(1 file)

Allow differerent kinds of 'additional comments' to be specified by a drop-down 
list. Specify the possible types in localconfig.
To install this, after applying the patch, you need to run checksetup, edit 
localconfig (if desired) and rerun checksetup.
Target Milestone: --- → Bugzilla 2.16
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
Keywords: patch, review
*** Bug 123304 has been marked as a duplicate of this bug. ***
Attachment #54191 - Flags: review?
This patch involves a schema change...  we're too close to 2.18 to take schema
changes at this point, so pushing it out.

reassigning to the patch author while I'm at it.
Assignee: justdave → martin.ellison
Component: Bugzilla-General → Creating/Changing Bugs
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
I'm not convinced of the value of this. I can see wars over the type of comments
arising ("This is a whining comment!") ("No it's not!"). And people will spend
ages fiddling with the classifications instead of doing real work.

Gerv
As I recollect, the intended value was for users who were only interested in 
particular kinds of comments e.g. test plans, test results. 
I like the idea; it's definitely useful for certain installations. There's some
bitrottage because of templates at least, but I could take a look at it. Martin,
would you be interested in bringing the patch up to date?
> I'm not convinced of the value of this.

Then make it configurable based on a boolean param.
Comment on attachment 54191 [details] [diff] [review]
Patch relative to current CVS to implement

Bitrotten. Martin: like kiko, I'd be interested too in an updated patch
againest the current CVS.
Attachment #54191 - Flags: review? → review-
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
I actually implemented something similar to this; however, in my patch you can
have multiple flags per comment (called comment_tags, actually) that describe
the comment. It's more generally useful infrastructure, I think.
*** Bug 73173 has been marked as a duplicate of this bug. ***
I agree with the description in Bug 313063 (RESOLVED INVALID) that this could be a very useful addition for those who wish to minimize the amount of bugspam they receive. Here's a quote from that bug:

> I propose bugzilla should have an extra field related to new comments that
> allows for a few choices for the user to define what their comment is.  For
> example, perhaps "discussion" will be the default and is just people talking
> about the bug.  Some other options could be "possible fix", "reproduce
> example", "administrative" (probably could be better worded).
> 
> Then, at the top, people could choose a filter for these, with "All", or only
> those options.  So, people who want to see how to generate the bug can choose
> "reproduce example".

CCing dueydotnet@hotmail.com who originally opened Bug 313063.

Prog.
The trunk is now frozen to prepare Bugzilla 2.22. Only bug fixes are accepted, no enhancement bugs. As this bug has a pretty low activity (especially from the assignee), it's retargetted to ---. If you want to work on it and you think you can have it fixed for 2.24, please retarget it accordingly (to 2.24).
Target Milestone: Bugzilla 2.22 → ---
*** Bug 313063 has been marked as a duplicate of this bug. ***
Any chance of bringing this patch up to speed now that the tree is unfrozen?
QA Contact: mattyt-bugzilla → default-qa
Assignee: martin.ellison → create-and-change
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 793963
You need to log in before you can comment on or make changes to this bug.