If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[v2.1] Update has_mobile_connection and is_cell_data_connected

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RobertC, Assigned: RobertC)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

3 years ago
has_mobile_connection and is_cell_data_connected from gaiatest/gaia_test.py need to be updated according to Bug 932619

At this time those 2 methods always return True.
(Assignee)

Comment 1

3 years ago
Created attachment 8475891 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23084

Started adhoc run to check that this change doesn't break the tests
http://jenkins1.qa.scl3.mozilla.com/view/Flame/job/flame.mozilla-central.ui.adhoc/100/
Attachment #8475891 - Flags: review?(viorela.ioia)
Attachment #8475891 - Flags: review?(florin.strugariu)
(Assignee)

Updated

3 years ago
Blocks: 1055983
Attachment #8475891 - Flags: review?(florin.strugariu) → review+
Comment on attachment 8475891 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23084

r+
Attachment #8475891 - Flags: review?(viorela.ioia) → review+
Merged: https://github.com/mozilla-b2g/gaia/commit/33e471f952876677d770a16842a9f50135e3d9ed
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Pretty sure this one is the cause of a perma-orange. See https://tbpl.mozilla.org/?tree=Gaia-Try&rev=9793d2384024 and https://tbpl.mozilla.org/php/getParsedLog.php?id=46554753&tree=Gaia-Try more specifically

Comment 5

3 years ago
Yep. I'll back it out.

Comment 6

3 years ago
Reverted:
https://github.com/mozilla-b2g/gaia/commit/6ad1fcc278938f792fcad4ecf8b722c4ce9c6795

This was failing on Gaia-Try so should not have been merged.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

3 years ago
Created attachment 8477405 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23205

Updated script to handle desktop runs.
Attachment #8475891 - Attachment is obsolete: true
Attachment #8477405 - Flags: review?(zcampbell)
Attachment #8477405 - Flags: review?(viorela.ioia)
Attachment #8477405 - Flags: review?(florin.strugariu)
Comment on attachment 8477405 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23205

r+, tests are passing on desktop b2g
Attachment #8477405 - Flags: review?(viorela.ioia) → review+

Comment 9

3 years ago
Comment on attachment 8477405 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23205

works ok but the code could be tidier.
Attachment #8477405 - Flags: review?(zcampbell) → review-
(Assignee)

Updated

3 years ago
Attachment #8477405 - Flags: review- → review?(zcampbell)

Comment 10

3 years ago
Comment on attachment 8477405 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23205

r+!
Attachment #8477405 - Flags: review?(zcampbell) → review+

Updated

3 years ago
Attachment #8477405 - Flags: review?(florin.strugariu)

Comment 11

3 years ago
Merged:
https://github.com/mozilla-b2g/gaia/commit/bcbfeb3bb6b3e87eea2fa32f4d58db812c18f0fd
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.