Registered users have lost access on the main blog (blog.mozilla.org)

VERIFIED FIXED

Status

Infrastructure & Operations
WebOps: IT-Managed Tools
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: craigcook, Assigned: jd)

Tracking

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1088] , URL)

(Reporter)

Description

4 years ago
At some point yesterday, perhaps during some migration/LDAP work, the list of users with access to post on the main Mozilla blog was purged. Afterwards it seems like some people got emails stating they had been given access, example:

Dear User,

You have just been permitted to access a new blog!

Username: mmanning@mozilla.com
Login: https://blog.mozilla.org/wp-login.php

We hope you enjoy your new weblog.
 Thanks!

--Wordpress

Upon attempting to log in they're only added as a "Subscriber" and don't actually have any access.


Other network blogs seem fine and their previous users intact, so it looks like only the main blog had its user list wiped somehow.

Additionally, I'm unable to modify the access level of any of these users, with the role dropdown just saying "no role for this site." I can add a user and give them a role at the time they're added, but can't change change roles when editing a registered user of any level.

Updated

4 years ago
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1088]
(Assignee)

Comment 1

4 years ago
This was an issue that was actually caused by work we did on Friday. I have restored the users as they were then. The users still have roles attached but the blog is not recognizing them. I am still working the issue, just giving an update.
Assignee: server-ops-webops → jcrowe
(Assignee)

Comment 2

4 years ago
The roles issue has been resolved now as well. It is possible that users will get another email about access, that depends on how Wordpress decides when to generate them. These emails can be safely ignored.

Thank you for reporting the issue, and please let me know if yo notice any additional troubles.

Regards
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

4 years ago
Everything seems back to normal now. Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.